High-Speed Digitizers

Showing results for 
Search instead for 
Did you mean: 

Problem: Cannot collect data at 2GS/s on 5152 with single channel

Go to solution

Hello again,

Using the "Configured Acquisition" labview example, I can run my 5152 digitizer at 2GS/s with TIS and "Enforce real time" enabled.  However, when try to implement this in a real program, I receive error -107413502, telling me that there's a problem with enabling TIS.  The property node I used to invoke it required me to change the value to 'write', so I am wondering if that is the issue.


The data is coming in on a ch0, and the clock is on External Trigger.  I've attached the scope configuration VI - if anyone could take a look and let me know what I'm doing wrong, I'd greatly appreciate it!





0 Kudos
Message 1 of 8

A correction to my last post - the error was -1074135024


Also, I have since specified ch0 as the 'Active Channel' aloing with enabling TIS.  The error remains.  



0 Kudos
Message 2 of 8

Hello Jamoore84,

I tried running the code that you attached and got an error associated with the Min Sampling Rate value.  By changing that value to 2e9, I was able to run the code with no problems.  Let me know you are still getting an error after changing that. 





0 Kudos
Message 3 of 8

Hi Christina,


This VI is implemented as a subVI in a larger program, with all those settings brought out to a main control panel.  I've tried running the scope at any sampling rate but I always get the same error.  Could it be a problem with how  the active channel is declared?  


I'll mess around with it some more, but no progress so far.


Thanks for your help,



0 Kudos
Message 4 of 8
Accepted by topic author jamoore84


Are you able to run it as a stand-alone VI without getting this error? 


0 Kudos
Message 5 of 8



Thanks for reminding me of the most simplest check - yes, this VI was able to run on its own.  This made me realize that the min sample rate was specified as 1e9 in the subVI.  I guess the problem was that the 1e9 in the subvI was supersceding the 2e9 specified on the main program front panel.


Either way, I have shown myself that the scope can collect at 2GS.  Now, however, there is a new error to debug, but this takes us outside of the scope of this thread. 🙂


Thanks for your wisdom,



0 Kudos
Message 6 of 8

For those following along at home, I was receiving Error -50150 when attempting to fetch records from memory with TIS and "Enable Records > Memory" enabled:

niPAL Error -50150 occurred:

The software has entered an unknown
state - usually as a result of a cascade failure induced by an unexpected
series of state inputs. The operation could not be completed as specified and
you should immediately terminate all further transactions if you are able to do


Status Code:-50150



This apparently is a driver problem and has been fixed with an update:




I'll check back and let everyone know if this solves my second problem.

0 Kudos
Message 7 of 8
After a long download and installation process, upgrading from NI-Scope 3.4.1f6 to 3.5.1 did solve my problem outlined in the previous post.
0 Kudos
Message 8 of 8