FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

fp-tb-10 ready light doesn't go on?


I have a fieldpoint system that consists of 2 controllers and approximately 10 modules.  The modules include a mixture of thermocouple, analog outputs, analog inputs, digital outputs and digital inputs.   The system has been operational for more than 2 years without a problem.

Recently, the communication with one of the FP-TB-10 modules stopped.  This module has 8 channels of DI and 2 channels of AO.  The only visible symptom of a problem is that the "ready light" does not light-up at all during or after powerup.  By perusing the knowledgebase and discussion forums, this seems to indicate that the module is not properly booting up.

I am trying to pointpoint where the problem may lie - with the FP-TB-10 module, with the individual channels, or perhaps with the inputs.  Or maybe I have some sort of loose connection?

I have another FP-TB-10 module right next to the malfunctioning unit - it works fine.   Therefore, I suspect the system power is OK.

I tried removing all of the individual channels from the malfunctioning unit and then powering it up.  The result was the same - no ready light.

Any other ideas? Suggestions?

0 Kudos
Message 1 of 4
   As I reported to a previous post, when i encountered this problem, all the FP chain, from a certain module on, didn't have READY LED lit, and it was due to a pin flexed in the backplane bus, I mean those pins located near the DIN rail, that carry backplane data.  When I straightened it back, all worked again.

   The module NEXT to the one not working, with optomux address GREATER than its own, is it working? I mean, if damaged module is at address 4, are modules at 5, 6... working?  If they aren't maybe you're facing my same problem...

0 Kudos
Message 2 of 4

Your message is very interesting... 

Modules upstream and downstream of the problem module are all working fine.  Their ready lights are "on" and I can access them from the NI software.

However, prior to the current state, the module in question had slightly different behaviour.   Upon power-up, the ready light would come "on" but some-time later (~5 minutes or so) after I tried to start the control software the software would give an error message and when I looked back at the hardware the ready light was now "off".  Thinking I might have a loose connection somewhere, I poked around and noticed that the module right next to the problematic module would "change state" when I jostled it.  By "changing state" I mean the channel LED's changed from on/off to off/on - so it looked like I did have a poor connection; maybe on the backplane line.  I tried to improve the connections on THAT module and it now behaves in a normal manner. 

0 Kudos
Message 3 of 4
Hi Lakeland,
   and thank you, because reporting the behavior you've noticed, that I wouldn't expect, I'll be able to quickly debug my HW problems, when they'll show!

   I thought that one broken module would have blocked backplane for sure, from that module to the last of the backplane...

0 Kudos
Message 4 of 4