FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

cFP-1804 connection in Max failed with General Error 6.0.8

Has anyone seen this error, or know why it may be occurring?


I was at a customer site, and tried to connect to a cFP-1804 running 6.0.8 in Max.  A yellow banner appeared at the top of Max, and stated that something to the affect that "IAK_General_Error" had occurred, and that I should contact NI.  I had to restart the cFP so that Max could connect to the device.


Any reasons why this may be occurring, and could this be a re-occurring problem?

0 Kudos
Message 1 of 4

Hello Joe C.


Was this the first time you were connecting to the cFP? And after restarting it were there any further issues? It shouldn't reoccur but could have various causes, possibly if IAK file changes were made but not saved the last time MAX was closed or if MAX was closed while attempting to save. I apologize, but it is a general error and without the code I can't find too many more specific causes. Please post again with more information if it there are further connection problems.


Thank you,

Deborah Y.

Deborah Burke
Senior LabVIEW Product Manager
Certified LabVIEW Architect
National Instruments
0 Kudos
Message 2 of 4

The cFP used to be connected to one PC and then we switched it to another.  There are a total of 3 cFP on the system, and only one of the three generated the ambiguous error.


I am guessing that action caused the cFP not to connect/get confused?

0 Kudos
Message 3 of 4

Hey Joe, 


Have you tried deleting the old IAK file, and making a new one in MAX? Thanks!



District Sales Engineer
0 Kudos
Message 4 of 4