FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

What causes :Error -33800 occurred at FP Write.vi

Dear All
 
I have a 2015 FP controller with 9 modules on its own bank and a 1601 module with two moduels a network bank. When creating a simple VI running on the FP controller that operates a DO on the 1601 network bank, I get a -3380 error code.
 
Error -33800 occurred at FP Write.vi
Possible reason(s):
FieldPoint:  Unknown communication error/warning.
 
Attached the VI returning the error, and the IAK file.
 
sincerely,
 
søren h. jensen
 
 
0 Kudos
Message 1 of 6
(3,877 Views)
The system would not let me attach the iak file, but here is the VI.

Message Edited by søren hallberg jensen on 12-12-2006 12:17 PM

0 Kudos
Message 2 of 6
(3,876 Views)
Trying to add the Iak file again.

Message Edited by søren hallberg jensen on 12-12-2006 12:18 PM

 

This file is an iak file, pls rename from .vi to .iak

Message Edited by søren hallberg jensen on 12-12-2006 12:19 PM

0 Kudos
Message 3 of 6
(3,880 Views)
It turns out that I could solve this -33800 problem, by specifying a timeserver to the network (1601 module). Initially I tried specifying the FP controller as the timeserver, but this did not work. Then I added the PC as the timeserver and this solved the problem. Attached find a screenshoot of the network modules in MAX, red boxes indicate old timestamp (I/O time not yet updated and new timestamp (I/O item updated).
 
I can find no logical explantion to the problem/solution, but it did cost me 2 days of troubbleshooting.
 
sincerely,
 
søren h. jensen
0 Kudos
Message 4 of 6
(3,863 Views)
Update 28 aug. 2007: Using LV 8.5 on FP controller. I ran into the same problem, updating the timeserver IP somehow fixed the problem once more. The timeserver can be set to the IP of the module/contrller itsel, the master computer (the PC) or, if networked modules (such as a FP-1601) to the controllers (FP-2015) IP address. I never really found out why this works, but somehow it does.
 
søren
0 Kudos
Message 5 of 6
(3,632 Views)
We have seen this error occour if there is an IP collision between the FP1601 network module and some other unit on the network. Therefore, if you ever encounter the -33800 error, please disconnect you device and ping your IP address to check if another device is using the same IP address.
0 Kudos
Message 6 of 6
(3,404 Views)