FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Software versions on fieldpoint controller

I was updating my cFP 2120 with the newer software versions (because I'm having some problems with communication via Datasocket and logos, which I'm going to post in the Labview forum, and thought this might help), updating all software versions to that of my PC.  Too late, I noticed that I updated the Labview RealTime to version 8.0 from version 7.1 but I am only running LV 7.1 both on my realtime app and on my PC.  Now when I try to set my LV target to my cFP I get the error: "Access denied: LabVIEW RT communication protocol version mismatch."  I'm assuming it's because of the 8.0/7.1 descrepancy.   So I tried to go back to LabView RealTime 7.1 on the cFP but when I do that it gives me the error: "Cannot process install because other dependencies are required: LabView RealTime 8.0."  I think I'm trapped in a circle!
 
So my most basic question is, How do I go back to the way it was?
 
My other question is, is there somewhere to get a list of the most current versions of the software that should be installed and are compatible with LV 7.1?  The ones that I need to know are the ones installed on the cFP controller (the list that appears when you right-click on Software and choose Add/Remove software):
Datasocket for LabVIEW Real-time - 4.3 or 4.2?
FieldPoint drivers - 5.1.2 or 5.1.0?
FieldPoint VI Manager - 4.0.0 or 3.1.0?
LabVIEW RealTime - 7.1 or 8.0?
NI-IrDA RT - 1.0.2 or 1.0.1? (I don't even know what this is)
NI-Serial RT - 2.5.6 is OK?
NI-VISA - 3.4.1 or 3.3.1 or 3.2?
NI-Watchdog - 2.1.4 is OK?
I also have a Network Variable Engine and a Variable Client Support but neither are installed on the cFP - don't know if they should be.
 
In general I'm using Fieldpoint 5.0, I'm assuming this is OK for LV 7.1??
 
Thanks for any insight.
0 Kudos
Message 1 of 22
(5,359 Views)
The FieldPoint 5.0 driver is actually compatible with only LabVIEW 8.0 and higher.  In order to use LabVIEW 7.1, you should install the RT versions of the FieldPoint driver that came with FieldPoint 4.1.

The ones in bold are important to get the versions correct.  For the other drivers, you can use whatever version you want:
 
Datasocket for LabVIEW Real-time - 4.3 or 4.2? Shouldn't matter, either of these are OK.
FieldPoint drivers - 5.1.0
FieldPoint VI Manager - 3.1.0
LabVIEW RealTime - 7.1
NI-IrDA RT - 1.0.2 or 1.0.1? Shouldn't matter, all of these are OK.
NI-Serial RT - 2.5.6 is OK?  Yes, this is OK.
NI-VISA - 3.4.1 or 3.3.1 or 3.2? Shouldn't matter, all of these are OK.
NI-Watchdog - 2.1.4 is OK? Yes, this is OK.

FieldPoint drivers 5.1.0 and FieldPoint VI Manager 3.1.0 are the versions of the FieldPoint driver that are compatible with LabVIEW 7.1 RT.

-Tommy
Message 2 of 22
(5,349 Views)

Great, that's exactly what I was looking for.  Thanks for your help.

Now for my PC, does this also mean I cannot use FieldPoint 5.0 for that either?  I have LV 7.1 there, but I installed Fieldpoint 5.0 and Max 4.0.  Will that be OK?

Message Edited by Hosehead on 08-23-2006 05:18 PM

0 Kudos
Message 3 of 22
(5,335 Views)
Yes, that will be OK.  You can use FieldPoint 5.0 on the host machine with LabVIEW 7.1.

-Tommy
0 Kudos
Message 4 of 22
(5,276 Views)

Hi !

I’m new on FP platform and I have quite the same problem :
on my controller (2120) :
fieldpoint drivers 5.1.2
fieldpoint Vi manager 4.0.0
real time 8.0
... (see the attached image)
this set-up was made by my predecessor (gone forever with the coding computer) for some obscure reasons and now my boss ask me to make some modification on the code, so I tried to deploy a new version on the FP and of course there is a version compatibility problem with versions installed on my computer
I have tried both LV 8.0, 8.2, LV real time 8.0, 8.2
I need LV and LV RT 8.2 to open the project and I was unable to export it to a previous version (8.0)
real time 8.0 seems to be needed by the controller (instead of 7.1) but when I try to deploy I think 8.2 is used by my computer
the LV code deployed on the controller works fine but we need to add some fonctionalities, I was thinking of re-inteall all the compatible versions but my boss doesn’t want me to modify the software installed on the controller because in case of a problem we have a production problem ... so I can just do watever I want with my computer
in he's memories a NI guy is came few months ago to make some modification on the coding computer (gone) but there is no information about what does he made…

is there is a way to get off this shit ?

sorry
for my poor english

matthieu

 

0 Kudos
Message 5 of 22
(4,942 Views)
thieumat -

The version of LabVIEW you use on your host PC must match the version on your controller.  So, if you are unable to change the version of LabVIEW RT installed on the controller, then you will need to use the same version on your host PC.  If the project and VIs are saved in LabVIEW 8.2, and the controller is using LabVIEW RT 8.0, then you will need to perform a Save for Previous on the project and the VIs to save it into 8.0.  Either that or you will need to convince your boss to upgrade the controller to LV RT 8.2. 

You mentioned you were unable to do the Save for Previous - what problems did you run into trying to do this?

-Tommy
0 Kudos
Message 6 of 22
(4,911 Views)
thank you for you answer Tom

upgrading the firmware seems to be the best solution, the other is to buy another controller to do my tests ...

for the "export to a previous version (8.0)" the error is :

fatal internal error : "linkperm.cpp", line 335
labview version 8.2
you will lose any unsaved work ...


it seems to append at the end of the operation
This file doesen't seems to exist on my computer (basic search) ...

matthieu

0 Kudos
Message 7 of 22
(4,898 Views)
matthieu -

The file mentioned in the error is a file in LabVIEW, that is useful for LabVIEW developers for tracking down where a crash occurs.  Is it possible to post the VIs saved in LV 8.2 that you cannot save for 8.0?  If so, we may be able to track down the problem for you.  Otherwise, upgrading the firmware on your controller is going to be your best alternative.

-Tommy
0 Kudos
Message 8 of 22
(4,887 Views)
Sorry Tom I can't post the code, so I'm going to do some checks, upgrade the firmware, and pray ...
if you see the head of a programmer at the top of a stick, it's me

thank you for your help
matthieu

0 Kudos
Message 9 of 22
(4,872 Views)
Ok, I'm trying to upgrade the labview realtime from 8.0 to 8.2 in my controller, like the 8 first steps here, and after a certain amount of time a "56 error code" appears, possible reason is timeout, so I put the timeout to the maximum (360000) but the error is the same, any idea ?

matthieu

Message Edité par thieumat le 01-21-2007 11:33 AM

0 Kudos
Message 10 of 22
(4,797 Views)