FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

No connection been identified between FP-2015 and DELL PC

Hi, all
 
I got a problem on the connection between FP-2015 and my Dell PC.
 
Hardware: FP-2015 + Dell PC Desktop Dimension 3100
 
Software: LabVIEW 7.1.1/8.0 + XP Operating System
 
After I connected FP-2015 to PC through ethernet connector, nothing appears in MAX 'remote system'. There is no connection signal between the two. I tried different PC (All Dell Model), different MAX version, different LV version.  ALL CANNOT work. But if I use a laptop, I got the connection works.
 
The cable is the correct crossover cable; I tried to reset the FP controller, and finally turned off the firewall of XP. Still cannot make the Desktop identify FP-2015!
 
Could anyone help me out here? Much time has been wasted. Thanks in advance.
0 Kudos
Message 1 of 6
(3,480 Views)
Hi zxustc,

If you were able to get the device working with a Laptop that's good news because we now know that the device is working, it's just a matter of getting these particular computers to work with it.

I think the best place to start would be to see what differences there were between the working laptop and the non-functioning computers.  Which version of the FieldPoint drivers are in use, which version of MAX, etc.

Let us know what the differences are so that we can start honing in from there.

Regards,
0 Kudos
Message 2 of 6
(3,474 Views)

Hi, Otis

Sorry to reply late. As you said, I checked the NI software version on these computers, and the details are shown below:

A. Laptop DELL Inspiron 8600 (The connection works):

    LabVIEW 7.1

    MAX 3.1.1.3003

    Field Point 4.1

B. PC I  DELL DIMENSION 3100 (No connection)

    LabVIEW 8.0

    MAX 4.0.2.3002

     Field Point 5.0

C. PC II DELL DIMENSION XPS T850 (No connection)

     LabVIEW 8.2

     MAX 4.1

     Field Point 5.0

Hope these information is helpful for you. Thanks for your help!

zxustc

 

 

0 Kudos
Message 3 of 6
(3,427 Views)
Hi zxustc,

That's great to see, and exactly what I thought might be happening.

You must make sure that the versions of FieldPoint are all the same across your different systems or it will cause problems like the ones you are having right now.

If you need the other computers to work you could either uninstall FP 5.0 and install FP 4.1, or you could upgrade your laptop to FP 5.0 and update the firmware on the FP-2015 to reflect the latest version of the firmware on the controller.

Once again, it's great to see this and the solution is actually fairly simple to enact.

Regards,
0 Kudos
Message 4 of 6
(3,402 Views)
zxustc,

Actually, I'm not so sure this is a driver versioning issue. You can have a different FieldPoint driver on your host than what is installed on the RT controller, and finding the controller in MAX should still work.  You will run into issues when you try to run a VI on the embedded system if the drivers are mismatched, but device discovery should still work.

This sounds more like a networking issue to me.  What is the IP address of the controller?  What is the IP address of the computers you are using?  MAX will only automatically find devices on the same subnet as the PC it is running on.  It wouldn't surprise me if the laptop has an IP address and a subnet mask that matches up with the controller's.  Since you can find the controller from the laptop, you should be able to quickly tell what the IP of the FieldPoint RT controller is.

Hope that helps.  I don't want you to have to uninstall/re-install a bunch of software if you don't have to.

-Tommy
0 Kudos
Message 5 of 6
(3,391 Views)
Otis, Tommy, Thanks a lot for your suggestions. I will try to work on it and let you informed the results. Thanks again!
0 Kudos
Message 6 of 6
(3,367 Views)