FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

NI 9214 FPGA I/O items missing (cRIO-9030 / NI 9144 combo)

I have a new cRIO-9030 and NI 9144 EtherCAT expansion chassis which I have configured and added to an existing LabVIEW project containing a cRIO-9012. When I searched for existing targets and devices, the modules were correctly detected (NI 9237, NI 9263 and NI 9265 on the cRIO-9030, and NI 9214 and NI 9477 on the NI 9144 chassis); however, the I/O items listed for the NI 9214 module show only the 16 thermocouple channels (TC0 through TC15). The four additional channels are not shown (Autozero and CJC0 through CJC2), although they did when the module was previously configured for the cRIO-9012.  Is this a known / compatibility issue with the NI 9144? or is there a configuration option I am missing? Does the terminal block need to be in place on the module for these I/O items to appear?

 

0 Kudos
Message 1 of 3
(4,960 Views)

Hi CFER_STS,

 

It looks like you have resolved your problem already here.  In the future, it might be in your best interest to try to keep to one subject board in case the conversation becomes split.  Additionally, in the case someone else has the same issue as you, it will be easier for them to find a possible solution so that they can try to resolve the issue on their own.  I'm glad that you were able to figure it out, though!

Chris H
Applications Engineer
National Instruments
0 Kudos
Message 2 of 3
(4,938 Views)

I posted in this forum by accident, so I reposted in the correct forum, but couldn't figure out how to delete this one.

0 Kudos
Message 3 of 3
(4,929 Views)