FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Lost Configuration on cFP RT

I just ran into a strange event.  I created and compiled an application in LV8 for a cFP-2100 on a 4-slot chassis.  It is a hydraulic pump & motor speed control application.  It has been running flawlessly on it's own for the past 6 months.  Each morning the entire system is powered up and then turned off again at night.  One day last week after the shop technician powered it up, there was simply no response from the controller (symptom: nothing moving).

The system is quite simple, using an AI-110 for inputs and a PWM-520 for outputs.  The AI-110 is configured such that all channels use 0-10 V inputs.  Strangely, when I inspected the system via MAX this morning, I quickly realized the system was broken because all the AI-110 inputs were configured for 0-20 mA!  How could this happen spontaneously??

Thanks,

David Moerman
TruView Technology Integration Ltd.
0 Kudos
Message 1 of 8
(5,078 Views)
Hello David,

One thing to realize is that a Fieldpoint configuration made within the LabVIEW 8 project will be completely different and independent of a Fieldpoint configuration made within Measurement & Automation Explorer (MAX).  When you create a Fieldpoint system with the LabVIEW Project Explorer, configure all the channel settings such as range, and create a VI that uses those Fieldpoint items from the Project, when you run that VI those configuration settings are downloaded and saved to the Fieldpoint controller.  On the other hand, within MAX you can also create and configure a Fieldpoint system under Data Neighborhood with different settings, and when this configuration is saved, these settings are downloaded to the Fieldpoint controller and overwrite any existing settings on there.  Does that explain why your settings in MAX didn't match those used within LabVIEW?

Is the Fieldpoint system up and running again or are you still experiencing issues?  Any time your Fieldpoint system becomes unresponsive, a good troubleshooting step to determine whats wrong with a Fieldpoint controller is to check the Status LED on the front of the controller.  Depending on the number of times the status light blinks, you can usually tell what type of error occurred.  The status light codes are listed in the cFP-21xx User Manual.

I hope this helps and let me know if you have any further questions.

Regards,
Travis G.
Applications Engineering
National Instruments
www.ni.com/support

Message Edited by Travis G. on 08-09-2006 05:24 PM

0 Kudos
Message 2 of 8
(5,072 Views)
Thanks Travis, that is a very useful perspective in distinguishing between the LV8 project settings vs. MAX configuration.  I will pay closer attention to this next time I'm on site.  However, I just checked the AI-110 configuration in my LV8 project (offline) and it appears the channels are still configured for 0 to 10.4 V, which is correct.  Is there anything else I need to do when deploying a built application to the RT target to ensure that these channel settings are always used no matter what?

Since I haven't received another service call it would seem everything is still running fine.  I should have mentioned that I did verify the status LED on the cFP controller was solid green, and 2 solid greens on each of the other modules as well.  There was no indication anything was wrong.

-Dave
0 Kudos
Message 3 of 8
(5,067 Views)
Hello Dave,

If you deploy your application to the RT target through the Build Specifications section of the LabVIEW 8 project, LabVIEW will take care of downloading all of the configuration settings, including channel range and filter settings, made in the Fieldpoint configuration within that project.  There's nothing else you have to explicitely do to make sure that those settings are used rather than the ones in MAX.  On the other hand, within MAX, whenever you make changes to the configuration settings under Data Neighborhood (which remember are indepenant of those within the LabVIEW project), when you choose to 'Apply' those changes or 'Save' your configuration, those settings will be downloaded and used. 

Let us know if you experience any more wierd issues with your Fieldpoint system.

Regards,
Travis G.
Applications Engineering
National Instruments
www.ni.com/support
0 Kudos
Message 4 of 8
(5,053 Views)
This is more clarification / information than anything else, in order to document the steps I took which resulted in a working system.

1)  First I diabled the startup VI (DIP switch), rebooted the cFP-2100, and connected my development laptop into the cFP system.  After opening the LV8 project, I opened the top-level VI under the cFP target, and clicked "Run", which deployed the Fieldpoint configuration that was stored in the project onto the cFP controller.  At this point I could see the cFP system wasn't receiving proper input values from the AI-110  (I had exposed these numbers on the top-level VI front panel).  So it appears simply re-deploying the cFP configuration from LabVIEW didn't fix it.

2)  I then shut down LabVIEW and started up MAX.  I did a "scan for devices" under the Remote Systems section, which populated the Device Neighborhood.  I then saw that the AI-110 channels seemed misconfigured for 0-20mA and changed them all to 0 to 10 V and did a Save, which deployed that MAX configuration back to the cFP.  I could then see that proper readings were being obtained by MAX.

3) I then shut down MAX, restarted the LV project, and again ran the top-level VI on the target.  It worked.  I then shut down LV8 again.

4) I rebooted the controller and let the original exe run.  It worked.  Note that I never did re-build the project using Build Specifications.

-Dave
0 Kudos
Message 5 of 8
(5,048 Views)
Hey Dave,

I justed noticed another feature today in the LabVIEW 8 project that pertains to our conversation above.  When you have your Fieldpoint controller and I/O modules identified as targets in the LabVIEW 8 project, you can right-click on the controller or I/O modules and there is a  button on the bottom left to 'Compare'.  This will query the actual settings on the Fieldpoint system and compare them to the settings you have configured in your project.  This may be another good troubleshooting tool if you ever run into this problem again.

Regards,
Travis G.
Applications Engineering
National Instruments
www.ni.com/support
0 Kudos
Message 6 of 8
(5,026 Views)

Hope this isn't hijacking this thread, but it seems pretty close to what I'm puzzling over.  This seems like it should be pretty straightforward, but I'm still semi-stuck.  If someone could tell me a 'best practices' approach to the following use case, I'd be grateful:

I have multiple FP-2015's which have identical module configurations.  I have one LVRT application which I want to deploy and run, unmodified, on each of them.  That is to say, I'd like the FPtag constants on the BD to not change since each application instance is only reading its local resources.

Whenever I try to configure the nodes using MAX, it seems that each node gets a uniquely-named FP configuration under its respective Data Neighborhood, which matches the ones which accumulate under my PC's local Data Neighborhood.  Clearly, I'm not getting the point here of how this should be managed.  What should the FPtag constants on the BD look like?

Is using MAX just the wrong approach?  The other messages in this thread would imply that the LV8 project interface (yup, I'm running LV8 now) would help untangle this.

Grateful for all advice,

 

Dave

David Boyd
Sr. Test Engineer
Abbott Labs
(lapsed) Certified LabVIEW Developer
0 Kudos
Message 7 of 8
(4,660 Views)
Hi David,
 
You can use MAX to initially configure and test the FP units, but then use the Project Explorer and configure your channels there to programmatically interact with your FP units. Hope this helps!
 
Regards,
Prashanth
0 Kudos
Message 8 of 8
(4,607 Views)