FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Getting Error -33800: FieldPoint: Unknown communication error/warning.



I've got a VI that I'm running embedded on a Compact FieldPoint cFP-2210 controller.  This controller is part of a network of five PXI backplanes.  Three of the backplanes have a cFP-2210 controller and the other two are backplane extenders with a cFP-1808 controller.  The VI's main purpose is to read the analog input modules on all five backplanes, including itself.  There is nothing special in the VI.  It simply reads from a pre-defined list of cFP addresses ("FieldPoint\ISDIWS2\cFP-AI-111 @4\All", "FieldPoint\ISDIWS3\cFP-AI-112 @4\All", etc.) with the FP Read VI in a for loop.  For the last few weeks I've been getting the same error as the one posted in this discussion forum:


It is an error -33800: unknown communication error/warning.  I get the error on a few of the modules in the network.  What makes this difficult to troubleshoot is that this error doesn't necessarily appear on the same modules every time.  For example, I was getting the error on an AI-112 module on the third backplane.  I followed the fix called out in the other disscussion (set the time server IP address for each cFP controller) and now the AI-112 module works just fine but I'm getting the same error on an AI-111 module on the fourth backplane that had been working fine before.  Yesterday the error was on an AI-112 on the second backplane.  The error seems to jump around to a different module if I reset various things (my computer, the cFP controllers, etc.).  I've seen this error show up on modules on all of the backplanes except for the one actually running the code.  I also have a VI that reads all of the RLY-421 modules in the network.  This VI will occasionally give me the -33800 error as well.


I have the IP addresses for the cFP controllers set up as through and all five have subnet masks of  I haven't set up the gateway or DNS server, although I've noticed that the two cFP-1808 controllers both come up with a DNS server of  If I clear the addresses out, they show up again within a few minutes.  The host computer is and also has a subnet mask.  I didn't have an eight-port hub to connect everything together, so I am running all six computers (five cFP controllers and main computer) through two four-port hubs.  One hub is connected into the other.


I also noticed that this same VI will run just fine if I run it from my computer rather than running it embedded.  However, for my final application I will need to run it embedded.  Has anyone else run into this problem?

Eric C
Systems Integrator, National Technical Systems
Certified LabVIEW Architect
0 Kudos
Message 1 of 3

Hi Eric NTS,

This sounds like a network traffic issue to me, especially since the error is not isolated to one single module. Have you ever gotten this error from the modules that are on the same backplane as the controller running the VI? Also, are really using network hubs or are they network switches? If they are hubs, then you might have too much network traffic which could result in this error in which case you might want o consider trying to find a switch.

Eric A.
National Instruments
Distributed I/O Product Support Engineer
0 Kudos
Message 2 of 3
Hi Eric A.,

Thank you for your insight.  I had one 10/100 hub and one 10/100/1000 switch.  I swapped the hub out with a second 10/100/1000 switch and the problems are still there.  I also tried replacing both switches with an eight-port Siemens se5940 business gateway.  I'm not sure where exactly that falls on the list of hubs and switches, but the problem was still there.  Swapping around my network cables between the two switches seems to also move the error around, so I agree that this sounds like a network issue.  I do see a lot of activity on the network ports for all five cFP controllers.  The Link/Activity lights are blinking at around six or seven times per second.  This seems to happen the second they are powered on and initialized.  However, I was just informed that something on our network is broadcasing a bunch of packets right now.  When I disconnect from the network the activity lights slow down to about one blink every two seconds.

One of my co-workers suggested putting a second network card in my computer and running the five backplanes on their own network.  I tried that first with the hub and the switch and still got the errors.  I then swapped the hub out with a second switch and after some minimal testing the errors seem to be gone.  I am going to continue doing testing, but this gives me hope that you were correct.  Eventually I'll be allowed to buy a 24-port switch and hopefully this should take care of the problem for good.  This is good for me to continue on with the project for now.  Thank you again for the help.
Eric C
Systems Integrator, National Technical Systems
Certified LabVIEW Architect
0 Kudos
Message 3 of 3