FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Field Point FP-1000 communication issue - Device found but offline in MAX

Hello,

 

I am trying to control several field point PLCs in a level tank. They are communicating through a FP-1000 module. I am able to add the devices through a configuration file in MAX. But there is an error saying " The device is offline. Make sure the device is connected and its power is on. " All of the field point PLCs have green light on for both " Power" and "Ready". I am not sure what the issue is here. I am using Labview 2014 and Field Point , VISA drivers are installed. Please see attached pictures for details.

 

Many Thanks

 

FLiu

Download All
0 Kudos
Message 1 of 5
(5,499 Views)

My first thought is that you do have device driver issues.  I believe either the latest LabVIEW, or the latest fieldpoint drivers are no longer compatible with the older Fieldpoint modules.

 

What versions of fieldoint  and VISA are you using?

Message 2 of 5
(5,485 Views)

Thanks for your reply. I installed the most updated version for both ones. It turns out the configuration file for FP-1000 bank points to the wrong COM port for the Serial communication. I am able to communicate with the system now. I do have another problem through. I only have excutable labview files and a configuration file for the control system that I am working with. The original VI project file were lost. After importing the right configuration file in MAX, I installed the excutables and tried to run it. There is no response at all.The labview only last a few seconds and stopped. Any thoughts are greatly appreciated.

 

Thanks

 

Fliu

0 Kudos
Message 3 of 5
(5,471 Views)

It could be any number of things that are hard-coded into your executable that no longer match the way your system is set up now.  Perhaps a file path that no longer exists.  Or your MAX configuration isn't the right configuration anymore.

 

I don't know if you are going to be able to do much other than looking harder for the lost VI files, or rewriting them from scratch.

Message 4 of 5
(5,458 Views)

Thank you for your reply. I have couple questions : 

(1) How would you suggest to design the excutables so that one installer can be used on many PCs with different COM ports set up ?

(2) Do I need to install MAX for excutables to run on a machine ? 

 

Thanks

 

FLiu

0 Kudos
Message 5 of 5
(5,439 Views)