FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot find dependent files subFieldPoint.llb and pid.llb for old LabVIEW 2009 program

I am trying to get an old LabVIEW program to work that originaly written in LabVIEW 2009 using the FieldPoint module.  (thats all the information I have on the old program)

 

I have installed LabVIEW 2009 sp1 and NI-FieldPoint 6.0.11. 

 

When I try to open the old .vi file, it is missing some dependent files:

 

\addons\_FieldPoint\express\FieldPointBlock.llb\subFieldPoint.vi 

and

\addons\control\pid\pid.llb\PID Setpoint Profile.vi

\addons\control\pid\pid.llb\PID (DBL).vi
\addons\control\pid\pid.llb\PID.vi

 

I am aware that in some cases the .vi is inside a .llb file but I do not have the .llb files either.

 

What do I need to do to install/get these files.

 

In my C:\Program Files (x86)\National Instruments\LabVIEW 2009\vi.lib\addons folder I only have

analyzer and database

 

 

Thanks

0 Kudos
Message 1 of 4
(5,189 Views)

Part of Control Design TooLkit?

0 Kudos
Message 2 of 4
(5,178 Views)

SLOVED

 

So FieldPoint 6.0.11 wasn't being intalled because I already had 14.5 installed (but gave no warnings or errors).  Uninstalling all FieldPoint versions and then installing 6.0.11 fixed the FieldPoint error. 

 

I am pretty sure I need FieldPoint 6.0.5 to work with the old .vi which I can not find anywhere... But thats another topic.

 

I Installing the PID and Fuzzy Logic Toolkit 2009 as RavensFan pointed out to fixed the PID errors.  It was kind of hard to find but eventualy I found it at http://www.ni.com/download/labview-pid-and-fuzzy-logic-toolkit-2009/3412/en/

0 Kudos
Message 3 of 4
(5,165 Views)

Yes.   PID Fuzzy Logic.  I just could not remember the name of that and the closest thing I found when I searched was the Control Design Toolkit.  I'm glad to hear you got it all working.

0 Kudos
Message 4 of 4
(5,152 Views)