FieldPoint Family

Showing results for 
Search instead for 
Did you mean: 

Cannot detect CFP 2000 on network



I am trying to detect a CFP 2000 device in the measurement and automation explorer software, the device and PC are on the same subnet and no firewalls are present yet there is nothing to select under remote systems.


When I switch the device on the status LED is continuous, then after 5-10 seconds flashes continuously. I have tried the reset IP switch then resetting but this does not work either.


I am new to using NI equipment but have been informed the device was working fine 4 weeks ago, and no changes have taken place since.  Any suggestions to get it working again?


Thanks for the help



0 Kudos
Message 1 of 6



The cFP should be flashing an error code.  It should flash x times at a constant rate, wait and flash the sequence again.  # of flashes is documented in user manual.

0 Kudos
Message 2 of 6

Thank you for the quick reply.  The status LED is continuously flashing and appears to be in no sequence, looking at the manual (quote below) this seems like there is no IP address assigned although according to the network administrator this should happen automatically.


"After about five seconds, the STATUS LED begins flashing. The cFP-20xx is ready to be configured, and you can install the FieldPoint

software.  If you have already assigned an IP address to the cFP-20xx, the STATUS LED turns off, the I/O module READY LEDs come on, and the cFP-20xx

is ready for use. The total boot time for a configured system is 30–45 seconds."





0 Kudos
Message 3 of 6



Use the DIP switches on the cFP-2000 to try and boot in safe mode.  Try resetting the IP settings as well.

Message 4 of 6

Hi Wayne


Thanks for the reply.  After trying everything, installing the most up to date drivers solved the problem and the PC now sees the device.  Now to improve my LabView skills to get it doing what I want!


Thanks for the help



0 Kudos
Message 5 of 6

What if there light on the network and the cFp2000 don't even go on, but we have internet from the on board controller. When looking in the measurement and automations explorer, under remote system, it shows disconnected, 


I am personally not familiar with this program and software at all, but was asked to replace the hardware (PC). It was not a reinstall, but I had a HDD image, so everything is the same other than the motherboard.

0 Kudos
Message 6 of 6