FIRST Tech Challenge Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Why can't I see FTC specific stuff?

Solved!
Go to solution

Hi all,

My team has a couple of dedicated Windows 7 64 bit laptops that have nothing on them except LabView LM, Solidworks and the FCS.  I am new to LV although I am an IT guy and have coded a few million lines of code...doesn't mean I haven't missed something stupid.  So...after installing LVLM and the FTC LabView toolkit, I am expecting to see some additional items on several screens.  There are no errors on install, but there are no extra features either.  For example, according to the tutorials, I should have two extra items in the "Challenge Me" area that are FTC specific.  All I have are the three default options.  I also do not have the "FTC Arm and Gripper" that I think shoul dshow up in new projects.  In addition, when I pull one of the FTC VI files and try to open it, I get a lot of "not found" errors for sub-VIs that appear to be FTC samantha specific.   I have tried reloading the FTC toolkit several times, but the result is always the message "software installed' Nothing installed or removed. 

I have unloaded and reloaded the entire LV and FTC packages on one machine with no change.  

Any ideas?     

Thanks,

Scott

0 Kudos
Message 1 of 6
(3,981 Views)

Hi hodgepodgerama,

Is it possible that you have more than one version of LabVIEW installed on the laptops? You are downloading LVLM from http://www.ni.com/download/labview-for-lego-mindstorms-2012-sp1/3877/en/ and LTMC from http://www.ni.com/download/labview-ftc-toolkit-2014-2015/4331/en/ ?

0 Kudos
Message 2 of 6
(2,801 Views)

Hi.  Thanks for responding.  Yes, it is the FTC version of the software and it took my FTC serial number.   Part of the problem is that there is no clearcut way to tell if the toolkit is installed.  A lot of older tutorials say I should see additional options under tutorial and challenge that are FTC specific.  I think those might be referring to the 2010 LV version.   I unloaded and reloaded everything on one machine and now I see "FTC Grabber Bot" or something similar when creating new projects, so I know something is now loaded. (If you just try repairing, the installer says there were no changes.)  That's 1 machine out of 4 working...maybe.  What would be really helpful is a listing of what is supposed to be included in the toolkit.  What is added?  What is different?   Can anybody provide that list of visible changes?   I'm guessing I'm not the only one struggling with this.  And since my journey started with the Samantha module responding as off-line because of my non-toolkit code, I'll bet good money that a LOT of poeple won't make the connection between Samantha/FCS not running and the LabView toolkit.

Does anyone have a list of changes?

Thanks,

Scott

0 Kudos
Message 3 of 6
(2,801 Views)
Solution
Accepted by topic author hodgepodgerama

Hi Scott,

The easiest indicator of whether LTMC is installed is whether or not you see "About LabVIEW Toolkit for MINDSTORMS Competitions" in the Help menu. But here's an extensive list:

- There will be a subpalette called "MCT" in the "MINDSTORMS Robotics" palette.

- The schematic editor will allow you to choose a MATRIX Controller on the sensor ports of the NXT.

- The Remote Control Editor will have a Generate Code button in the upper left corner.

- The New Program dialog will include the FTC Arm & Gripper project.

- The Robot Project Center will have "FTC Autonomous VI" and "FTC Teleoperated VI" in the New VI dropdown.

0 Kudos
Message 4 of 6
(2,801 Views)

I tried to download LTMC using the NI downloader, and it didn't work for me either. Using the Standard Download did work for me. I'm having the issue looked into.

0 Kudos
Message 5 of 6
(2,801 Views)

This is excellent information.  Thank you very much! 

I installed everything on yet another computer today but I installed all the patches on LVLM (including F4 which was just released) before installing the kit.  That seems to be the winning sequence. 

I am not sure about the toolkit installer.  I haven't noticed any problem with that part. 

Thanks again! 

0 Kudos
Message 6 of 6
(2,801 Views)