FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

roboRIO Firmware Update Page Blank

Go to solution


We are trying to update the firmware on last years roboRIO to the 2016 version. We are able to the connect to the roboRIO (at with the USB cable and Firefox and the webpag comes up. What is strange is that the System Settings page, where you update the firmware is blank. All of the icons on the left side are still there for networking, security, web server settingsm, etc. and they all work except fot the System Settings icon. You press on it and nothing happens. We've tried going into safeboot mode with the same result.

Anyone have any ideas?


Mr. Dackow

Team 1099

0 Kudos
Message 1 of 3

Mr. Dackow,

Have you tried reimaging the roboRIO before accessing the web interface? Also, it may be worth trying it in Internet Explorer--I know there have been mixed results with Firefox and Chrome. Can you post a screenshot of the issue as well?



Message 2 of 3
Accepted by topic author bohdand

Hi Aprillest,

Thanks for the suggestion. What I did was use NI Max to download the firmware while in safe mode and that corrected the problem.

Mr. Dackow

0 Kudos
Message 3 of 3