FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

RoboRIO Imaging Error

I have a roboRIO that one day decided it did not want to cooperate with a java code upload. After doing some basic trouble shooting I decided that a reasonable course of action would be to reimage it. After booting up the roboRIO imaging software and connecting over USB I was greated with this error:

Unable to download image to target. Unable to complete operation because of unexpected error:nisyscfg.lvlib:Initialize (Helper).vi:3930001<APPEND>

<b> Complete call chain:</b>

     nisyscfg.lvlib:lnitialize (Helper).vi:3930001




I followed the instructions in this troubleshooting guide.

In NI MAX it showed up under "Devices and Interfaces" as "NI roboRIO [roboRIO-2914-FRC]" not in "Remote Systems". I also confirmed that I have "NI-RIO 15.0".



0 Kudos
Message 1 of 13

If it's not showing up under Remote Systems, it's not a huge surprise the imaging tool was unsuccessful in sending the image.

Do you have this problem over both USB and Ethernet?  Have you tried other computers with the same result?  Are there other USB ports on the computer with the issue?

0 Kudos
Message 2 of 13

It's tethered over USB but I can connect to it over Ethernet (I don't know

if you can image over Ethernet). There are other USB ports but I've only

tested with the two front USB ports. I've been able to transfer between

this computer and the roborio before (uploading Java code) so I don't think

the problem is with the computer.

When I get home I will try rear USB and connecting Ethernet directly

between the computer and roborio (instead of over my home network). I will

also try a different computer if neither of the previous options work.

0 Kudos
Message 3 of 13

You can image over Ethernet.  It's generally suggested you use USB as it tends to be more stable.  I'm more trying to narrow down what exactly is causing the strange behavior where the device doesn't show up under the remote systems.

What's the behavior of your status light?

0 Kudos
Message 4 of 13

The status light is orange and blinks three times, then waits and repeats.

0 Kudos
Message 5 of 13

Three blinks means you're in safe mode.  If you tap RESET and release, does it return to this state?  If not, what happens to the STATUS light now?

0 Kudos
Message 6 of 13

When I tap the reset button the status light turns off and the usb driver for the roboRIO nolonger picks it up. It also doesn't show up over ethernet after tapping the reset button. I also tried connected the roboRIO directly to the back of the computer with Ethernet and while I could get to the config page the imaging tool and NI MAX both showed nothing.

0 Kudos
Message 7 of 13

It sounds like something isn't quite right.  I'd try reimaging it freshly and see if that clears up the issue you're running into.

0 Kudos
Message 8 of 13

I believe that's what I've been trying to do. I ran into this problem while

attempting to reimage via the roboRIO imaging tool.

0 Kudos
Message 9 of 13

You mentioned being able to see it in MAX.  At any point have you been able to get it to show up under Remote Systems?

If so, take a look at the force safe mode setting and see what it gives you.

If not, give the support line a call and ask for the recovery steps.

0 Kudos
Message 10 of 13