FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Difficulty connecting a Windows 10 laptop to our roboRIO over wifi (OM5P-AN)

We're having problems connecting a Windows 10 laptop to our roboRIO over wifi (using the new 2016 OM5P-AN access point), via the driver station.

We have configured the OM5P-AN according to the WPI instructions. We are using a new Win 10 laptop that has been configured using the latest FRC 2016 software. We have imaged the RoboRIO with the 2016 image.  We are using the 2016 Driver Station.

Here is the data that we have collected.

When connected to the roboRIO via USB (directly) and/or ethernet cable (through the OM5P-AN):

We can access the roboRIO dashboard via its webserver (we had to use Firefox -- IE and Chrome don't support Silverlight) using the URL roboRIO-2635-FRC.local

The dashboard tells us that the IP address for the roboRIO is

We can successfully ping

We can successfully ping roboRIO-2635-FRC.local

We can successfully connect to the roboRIO via the DS

However, when connected to the roboRIO via wifi (through the OM5P-AN):

We cannot access the roboRIO dashboard using the URL roboRIO-2635-FRC.local, but we can access it via the IP

Interestingly enough, we can also access the dashboard via the URL roboRIO-2635-FRC.lan

We can successfully ping the roboRIO at and roboRIO-2635-FRC.lan

We cannot get a ping at roboRIO-2635-FRC.local

We cannot successfully connect to the roboRIO via the DS

We have tried turning off windows defender and retrying connection via wifi without success.

We have checked and verified that the mDNS service nimDNSResponder is running.

The laptop does not have Inventor installed (there were some reports on Chief Delphi that Inventor could interfere with mDNS).

We have used the same computer as in the above test and used it to connect and control a robot that is using a new roboRIO, configured for 2016, with the only different that it is using last year's DAP-1522 wifi router. This all worked just fine -- we had no problems connecting with the drive station through wifi.

This all appears to point to a problem with mDNS on the OM5P-AN when connected via wifi. 

Is this strictly a Windows 10 problem? Any ideas for further troubleshooting?  Has anyone successfully used this combination (win 10, roboRIO, wifi over OM5P-AN)?  Is anyone successfully using this combination, but with Win8/8.1 or Win7?

0 Kudos
Message 1 of 15


When I get to my team later tonight I'll take a look at which of our laptops we've been using so far to work with the new router.  We do have one that we had up and running with the robot so we could control it wirelessly.  I'm not 100% sure if it was one of our Win10 machines or the Win7 machine.  When I know, I'll reach out to let you know.

That means one of your last two questions is a yes.  We've successfully set it up with one of the two configurations.  If you're interested in trying to figure it out before I can reach out, you might try a Win7 machine to see if that runs more smoothly for you.

With the Win10 setup, are you able to set the project to that specific IP address in properties and then communicate wirelessly with the robot?

0 Kudos
Message 2 of 15

Hi Darrell,

Another team recently had a similar issue with Windows 10 and they were able to resolve it by reconfiguring the Radio then when connecting over WIFI the issue was that they configured the new network as a public network. Instead, they had to configure it as a Home or Work network. I don't think this would block the mDNS but it is something to try.

Do you have any other Firewall or AntiVirus setup besides Windows Defender?

The team with a similar issue also disabled all other Network Adapters (including the wifi) when configuring the radio. Again, something else to try.

Brian H. -- Electronics & Measurements Product Marketing Manager
0 Kudos
Message 3 of 15


Thanks for verifying that it is possible for it to work, perhaps on Win7. 

We are able to use the specific IP address of the roboRIO to ping it wirelessly.  We can even ping it at roboRIO-2635-FRC.LAN (I'm not sure how we figured that out).

The problem is that the driver station appears to want to use the roboRIO-2635-FRC.local address to connect.  So we aren't getting robot communication with the driver station.  I haven't seen any way to enter a hard-coded IP address for the DS to use.

0 Kudos
Message 4 of 15

The public vs. home network is an interesting clue.  We will try that as well.

We believe that the only firewall / antivirus that we have is Windows Defender.  We tried completly turning it off and it didn't seem to help with the observed problem.

0 Kudos
Message 5 of 15

If you know the IP address of the roboRIO you should be able to put that in the Team Number section of the DS and connect.


Brian H. -- Electronics & Measurements Product Marketing Manager
0 Kudos
Message 6 of 15

Do you mean to literally use "" in place of "2635" for the team number field on the driver station?

See for the available options on the 2016 driver station.  I don't see a place to specify the IP address.

0 Kudos
Message 7 of 15

Yep. That is what I mean. In place of team number.

Brian H. -- Electronics & Measurements Product Marketing Manager
0 Kudos
Message 8 of 15

Didn’t know that was an option! We’ll give it a try.

0 Kudos
Message 9 of 15

We tried configuring the Wi-Fi network as a private network (it defaults to public).  Here's a link that describes how to do this (it's not particularly obvious in Win 10):

Unfortunately, this didn't seem to have any impact on the problem of connecting the drive station to the roborio via Wi-Fi. 

We also tried the feature of the driver station that allows an IP address to be entered directly, in place of the team number setting.  This worked quite well!  We could put the IP address in directly ( and we got green lights for the driver station comm.  We also tried entering "roboRIO-2635-FRC.LAN" in this field.  This also worked!  This is a helpful workaround.

0 Kudos
Message 10 of 15