Digital Multimeters (DMMs) and Precision DC Sources

cancel
Showing results for 
Search instead for 
Did you mean: 

Why my DMM reads -999

Hello all,

 

I was wondering why my DMM occasionally returns -999 when asked to do a voltage measurement? It's a PXI 4070 and we're calling from an IVI step type in Teststand.

 

It's quite likely due to switching, gating that there is no voltage present at the DMM but why does it return -999.

 

Also sometimes get NaN (not a number) returned, is it the same error condition as -999?

 

Thanks

 

Matt

0 Kudos
Message 1 of 3
(5,151 Views)

Hey Matt,

 

Tell us more about your test setup.  What voltage range are you in?  How fast are you sampling?  What is the amplitude of a typical reading?

 

The NaN sounds like you're exceeding the 300Vrms limit of the DMM.    I recommend running your DMM in digitizer mode using the Fetch and Graph Waveform example located in the example finder at Hardware Input and Output»Modular Instruments»NI-DMM»Acquiring Waveforms.  I recommend sampling at the full 1.8MS/s for this test.  This will let you see if you're DMM is subjected to any large voltage transients as you switch between your DUTs.  If you're missing any y values for a particular time (x axis), then at least one of your DUT measurements is exceeding the maximum input of the 4070.

 

If you have missing data, then unplug the DMM leads and run the test again.  With all leads disconnected, the voltage measurements should center around 0V; the readings won't be exactly zero because the HI/LO leads have 10GΩ or so of resistance, so stray charge will build up... but it definitely shouldn't be -999; more like 0±100uV or so.

 

The -999 issue might or might not be related to this.  How often does -999 occur?  Does it happen more often with a particular DUT, at a particular step in sequence, or at a particular time in the code execution?

-John Sullivan
Problem Solver
0 Kudos
Message 2 of 3
(5,148 Views)

Thanks for that. I don't think my question was worded very well, what I really wanted to know was what the difference was between when NaN and -999 are returned. I received this response from NI Technical Support.

 

"Essentially if you receive -999 from a DMM it is considered as an Out of Range signal. One of the reasons you receive -999 in Teststand instead of NaN is that Teststand does not automatically process NaN like in LabVIEW. Instead it uses the -999 notation for an Out of Range Signal.

This also depends on the driver layers that you are using. IVI in Teststand will give you -999 but NI-DMM in LabVIEW is set up to give you NaN. The message is the same!

If you prefer to see NaN in Teststand, you can call a LabVIEW VI to take the measurement and then transfer the result into Teststand. Here is how you can use NaN in Teststand: http://digital.ni.com/public.nsf/allkb/6B392861F47A2F1286256A39004D4BDD?OpenDocument"

 

Cheers

 

Matt

 

 

Message 3 of 3
(5,127 Views)