Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble reading an EPC Model 755A encoder wired to NI 9401 module

Hello,

 

It seems after reviewing other similar posts on the forum, I am still unable to read a signal from my encoder (data sheet attached for reference with encoder specific details highlighted on first page).  I have double and triple checked the connections to make sure the pinout in correct.  Here is how I have it:

 

White: +VDC - External DC Power Supply (5 - 24 VDC)

Black: COM - Ground

Brown: A - Pin 14

Red: B - Pin 17

Orange: Z - Pin 16

 

I have the NI 9401 module in an NI cDAQ-9174 4-slot chassis.  I've created a task in MAX to try and measure the angular position but have been unsuccessful in gathering any data.  The only thing I have been able to come up with so far is that output of the encoder is given in mA on the data sheet and I'm trying to use a DI/O module to read the signal.  Could this be the problem?  I'm quite new to the whole encoder world, or DAQ and LabView in general, so I apologize in advance if this has been asked before.  I've also tried setting up some simple LabView code to read the encoder but with similar results.  Any help would be greatly appreciated.  If I can provide any more detail or there is anything I left out, please let me know.  Thank you in advance for your help.

 

-Dustin

0 Kudos
Message 1 of 2
(2,408 Views)

Problem solved.  Found some info on pull-up resistors on the forum and did some further research.  The encoder is an open collector type and needed the pull-up resistor between each output and the voltage source.  Everything is working fine now.

 

Dustin

0 Kudos
Message 2 of 2
(2,392 Views)