Digital I/O

Showing results for 
Search instead for 
Did you mean: 

DAQ randomly resets itself or malfunctions

Hi, I am using a DIO 24 port DAQ in conjuction with LabVIEW program. The DAQ is programed to output a square wave that is sent to different buttons on a remote control. The DAQ is configured to be all output and all low. Sometimes the DAQ will malfunction and begin sending continuous signals to any random port on. These signals are random; sometimes it will just keep firing one signal, sometimes it will go back and forth between a few of them. The problem sometimes goes away if I reconfigure the DAQ, but sometimes that doesn't work and it just stops on its own. The DAQ keeps re-setting itself; how do I perminently configure the DAQ?


Can anyone tell me why this is happening or how to fix it? It doesn't seem to have any corrilation to our LabVIEW programing, or really to anything else for that matter. 

0 Kudos
Message 1 of 7

Hello scotths,


This is an interesting issue; let see if we can solve it. When you configure your DAQ device within LabVIEW, the device settings should not change on their own. To better troubleshoot this issue, I have a few questions.


1. What type of continuous signals are you seeing? Is it noise or a more defined pattern?


2. When do these "malfunctions" occur? Do they happen in the middle of your program or at the beginning of certain runs?


3. What is the model of the DAQ device you are using?


4. Is any other program using this device?


Abram Rose

Applications Engineer

National Instruments 

0 Kudos
Message 2 of 7



I've got the same problem with NI USB-6501 (OEM). The device resets spontaneously, making all ports set as outputs with pullups and invalidating all tasks related to it. I noticed it happens when I switch relays using DAQ (with proper signal driving, of course). Despite that, I don't think that DAQ resets because it lacks power - it is exclusively supplied by USB port, so there should be plenty. The grounds of both devices are well connected.

The outputs are, as far as I'm concerned, always on desired levels.


My question is whether DAQ has any means of protection, forcing it to reset in any circumstances (Like PCs reset when CPU overheats or PSU fails). I did not design the system so narrowing possibilities would help me debug it. Somehow I've got the feeling it's a feature and not a bug after all. 😉

0 Kudos
Message 3 of 7



If you run the task without the relays connected to the device, do you still have the same problem?

I think that the problem might not be the DAQ device but the USB port that should provide the current.

Have you run your application on a different computer or USB port? Are you using a laptop or a desktop?



Esteban R.

0 Kudos
Message 4 of 7

Hello, thank you for your support!


It seems that the problem is with the design of the driven device itself. DAQ resets even when it is only connected with system ground (all ports disconnected) and the relays are switched manually. It seems that the system's ground node is somehow foating while switching relays.

I too came to the conclusion there might be something wrong with USB connection rather than DAQ itself. I use Dell desktop and I tried USB ports on front and back of the machine. Right now I'm trying to get a USB hub with external power supply to see if it helps.


I'll report back once I solve the problem. Thanks!

0 Kudos
Message 5 of 7

Are the relays powered by DC? If so, do you have reverse biased diodes or transient snubbers across their coils?



"It’s the questions that drive us.”
0 Kudos
Message 6 of 7


Yes, relays are driven by 5V DC. There are reverse biased diodes across them (according to the schematic, these are Zener diodes of an unknown make or model). That's up about that?

Anyhoo, I've done what I promised yesterday and tried connecting DAQ through a usb hub. At first, Windows infomed me that the hub cannot provide enough current to power the DAQ, but after plugging the hub to external power supply, everything seems to work okay.

I guess there must be something very wrong with the ground node of this system. I already suggested that we shall redesign and rebuild the device, since this is not the only flaw in it.


Anyway, here's a tip to anyone experiencing the problem from the main topic of this thread: Try connecting your DAQ via USB hub with external power supply. It worked for me!

0 Kudos
Message 7 of 7