From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

Windows vista ultimate 64 bit PDF export error

Go to solution

Hi there, I'm using diadem 11.0 and  i have a big problem with my new os.

When i try to export a report in pdf i get a print error in the status of the "diadem pdf export" printer.

Any idea or solution for fix this problem ?


0 Kudos
Message 1 of 11

Hi lerman,


Try this.  First shut down DIAdem, then using the Windows Start Menu in the lower-left-hand corner of your computer, navigate to the menu "Start >> Settings >> Printers and Faxes >> DIAdem PDF Export" then right-click on the DIAdem printer driver and select the "Delete" menu.  Now restart DIAdem.  This should re-create the DIAdem printer driver correctly-- if not, let us know about it.


Brad Turpin
DIAdem Product Support Engineer

National Instruments

0 Kudos
Message 2 of 11

Thanks a lot for the suggestion Brad, but i have tried this already and it didn't solve my problem.

Even if i delete the printer i still get the error.

Message Edited by Ierman on 09-04-2009 10:44 AM
0 Kudos
Message 3 of 11

Hi lerman,


I ran this issue by R&D, and this is what they additionally suggested:

1.  You must have Administrative Provileges

2.  Delete the DIAdem PDF Printer from the Printers dialog (as already described)

3.  Delete the Registry Key "HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\DIAdem\Shared"

4.  Delete the Registry Variables "CLSID", "GUID" and "PDF Version"

5.  Restart DIAdem (with Administrative Privileges)

Did you say what your new OS is?

Brad Turpin

DIAdem Product Support Engineer
National Instruments

0 Kudos
Message 4 of 11
Thanks a lot Brad, i've tried to follow your instructions but i wasn't able to find those keys in the path you told me in the registry.

Instead of  "HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\DIAdem\Shared" in my os (vista ultimate 64bit) i've found the right keys in "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\National Instruments\DIAdem\Shared"

I've deleted the printer and the keys/variables, rebooted the pc, restarted Diadem and tried to export a pdf, but still no luck.

After this, I tried to check in the registry and all the keys/variables were restored. Same goes for the printer.

I even tried to reinstall diadem 3 times but nothing changed, i'm still getting an error with the pdf export.

I wonder if it's possible to use a new version of the amyuni pdf converter or something like that..


Ierman Gert



0 Kudos
Message 5 of 11

Hi lerman,


I talked to R&D again and told them of all that you'd tried.  They set up a test system with DIAdem 11.0 and Windows Vista Ultimate 64 and the PDF export worked fine for them.  So R&D firmly believes this scenario "should" work.  Perhaps there's some other difference between your computer and theirs.  But they made another suggestion that we can try.  Apparently the PDF printer driver that DIAdem ships was upgraded in the DIAdem 11.1 version, and the upgrades listed something like "better support for Vista".  Would you be willing to download the evaluation version of DIAdem 11.1 and try that on your computer to see if the PDF output works?  It's even possible that the 11.1 PDF printer will replace the 11.0 PDF printer-- I'm not sure if they install side by side or clobber each other.


Please let us know what you find,

Brad Turpin
DIAdem Product Support Engineer
National Instruments

0 Kudos
Message 6 of 11
Accepted by topic author Ierman

Thanks for the support Brad, i have tried to download and install diadem 11.1 but  it didn't solve the problem.

After that i've tried to search in the amyuni forum for a solution and i found out this (it solved my problem)


Windows Vista:

  1. Make sure that you are logged in as Windows administrator.
  2. Click the Windows button and click Printers.
  3. Right-click the Diadem pdf Export and select Properties
  4. Click the Ports tab, then click the Add Port button.
    Note: If the Ports tab is greyed out, right-click the Diadem Pdf Export icon and select Run as admin.
  5. Select Local Port and click the New Port button.
  6. Enter PDF1 for the new port name and click OK. Close the Printer Ports window.
  7. Put a checkmark in the box next to the PDF1 port if it is not already checked.
  8. Click on the Advanced tab.
  9. Select the Spool print documents radio button to make the options below it clickable.
  10. Clear (uncheck) the box labeled Enable advanced printing features by clicking it.
  11. Select the Print directly to printer radio button to make the options below not clickable.
  12. Click the Apply button, then click OK.
  13. Important: In order for the changes to take effect, you must restart your computer.
    Reboot your computer and then try to print, email, or create a pdf from Diadem.


Ierman Gert

Message 7 of 11

I have tried all of these steps and I am still experiencing this error upon export. (See attachment).  I am running this on a Server 2008 machine with admin rights.


0 Kudos
Message 8 of 11

Hi cbauer,


What version of DIAdem are you running on Windows Server 2008?  Did it used to work and now it doesn't, or has it never worked?  Does it work on any other Windows Server 2008 computers you've tried, or does it consistently show this error on all Windows Server 2008 computers on your end?  DIAdem 2010 was tested in Windows Server 2008, so I'm confident this scenario "should" work.


Brad Turpin

DIAdem Product Support Engineer

National Instruments

0 Kudos
Message 9 of 11

It is DIAdem 2010 SP1.

No, it has never worked on this particular server.

Yes, it works on several, i.e. 3-4, server 2008 installation we have used.

I am sure it should work as well since I have had it work on other servers.

0 Kudos
Message 10 of 11