Showing results for 
Search instead for 
Did you mean: 

DIAdem bus log converter .tdms export and DIAdem base licence

Go to solution



I use a DIAdem Advanced Edition to convert log files (vector ascii) to .tdms files with the "Bus Log Converter".

I send theses .tdms files to my colleagues so they can work on the analysis with a DIAdem Base Edition.

Since many month, it worked very well.

But since a few days, the .tdms files that were generated by the Advanced Edition no longer contain any data, except a signal names " <!xml ", when has been read by the Base Edition. You can see this in the "data_missing" attached .jpg file.

But, when the .tdms files are opened with the Advanced Edition, everything still remain good...! You can see this in the "data_not_missing" attached .jpg file.


Do you think I'm facing a license issue or is it something else ?

By advance, thank you for your attention

0 Kudos
Message 1 of 11

Hi Ariel_aka_Atryou,


I am pretty sure that this is not a license problem.


Do you use the same DIAdem version on both PCs?

Which version do you use?

Does this happen only with Bus Log converted data or also with any other data?

Which DataPlugins do have installed on both PCs (can you provide screenshots)?

Are you aware of any changes to any of the PCs?




0 Kudos
Message 2 of 11



thank you for your quick answer

I use a computer with the DIAdem Advanced Edition to generate .tdms files from vector ascii log files with the bus log converter

I send this .tdms files to my colleagues in order to be used on another computer with the DIAdem Base Edition.

The point is that it worked for nearly a year.

It only happen with bus Log Converted datas, no problem with other kind of .tdms files

As far as I know, no changes has been done on the computers, except for windows updates

You can see, in attached files, screenshots of the data plug-ins we own on each version of DIAdem 


Once again, thank you for your help

Download All
0 Kudos
Message 3 of 11

Hi Ariel_aka_Atryou,


The BusLogConverter stores the data as TDM file (not as TDMS) and in the Base Edition is a DataPlugin named “ASC_DataPlugin” registered that uses the “TDM” extension. Maybe this is the reason for the problem on the other PC.




0 Kudos
Message 4 of 11

Hello again,


yes you're right, sorry for this mistake, bus log converter files are .tdm and not .tdms.

However, I tried to disable the "ASC_DataPlugin", as you can see in attached file, but the behavior is still the same.

I tried to disable all dataplugins except those for TDM and TDMS, but the problem still remain the same

I tried to reset the DataFinder's index too, but it still not resolved the problem


Thanks again for your help

0 Kudos
Message 5 of 11

Hello Ariel_aka_Atryou,


did you try "Reset Folder" via the context menu?






0 Kudos
Message 6 of 11



I didn't found the function you are showing but I found something that I think is the same in the configuration windows of the datafinder (you can see a screenshot of what i'm talking in attached files). Is it this?

Or, if not, where can I find the menu you were showing me in your previous screenshot please ?



0 Kudos
Message 7 of 11

Hello Ariel_aka_Atryou,


You are pointing to the reindex function for a certain DataPlugin. In my case it is the whole folder (independent of the DataPlugin) which will be reindexed. You find this function by opening the context menu of the folder in the NAVIGATOR tree. But in the end is the result the same.




0 Kudos
Message 8 of 11



Maybe we don't work with the same version of DIAdem (I use the 2018) because when I do a right click on folders in the NAVIGATOR tree, I get the context menu you can see in attached files (base_version_navig_folder_context_menu.jpg). As you can see, there is no "index folder" function...

But, you can also see in attached files (base_version_navig_file_context_menu.jpg) that there is an "open with" function in the context menu of a file. So I tried it and get the window you can also see in attached files (base_version_open_with_function.jpg). When I select the ASC_DataPlugin, I still got the problem but when I select the "National Instruments TDM Files", everything get back to normal and I can get my data in the data portal.

So I think you were right about the origin of the problem with the DataPlugin. But when I disabled this ASC_DataPlugin in the DataFinder configuration windows, it didn't changed anything...


Do you think I should erase this DataPlugin or is there another way to set the NI one as default ?


Thank you again for your help

0 Kudos
Message 9 of 11
Accepted by topic author Ariel_aka_Atryou

Hello Ariel_aka_Atryou,


Yes, I work with the latest DIAdem version 2022, but you don’t see this context menu because you work with the “My Computer” area and not with the “Search area”.



This is also the reason why you still have the problem. Unselect a DataPlugin works only for the “Search area”. You can try to change the order of the DataPlugins.



But, removing this DataPlugin is the best option or to use “Open with”.


The important thing is: we have found the root cause – the second DataPlugin with the same extension “TDM”.




0 Kudos
Message 10 of 11