Community Documents

Showing results for 
Search instead for 
Did you mean: 

VI Snippet Quick Drop Plugins

Two of my favourite LabVIEW 2009 features are VI Snippets and Quick Drop Plugins.  I love being able to drag images of code right into LabVIEW but I don't like the fact that drag and drop doesn't work directly from my browser of choice (currently Google Chrome, previously Firefox).

Fetching Snippets

To get around this problem I have created a Quick Drop Plugin that will fetch a VI Snippet for you when you drag the URL into LabVIEW from Chrome or Firefox.  To install simply unzip the attached Fetch to <LabVIEW 2009>\resource\dialog\QuickDrop\plugins\.

Now whenever you drag a snippet into LabVIEW and see something like this:

aa - drag url.png

All you need to do is select the comment and hit <Ctrl-Space> to bring up the Quick Drop window and then press <Ctrl-U> (for URL) to replace the URL with the code contained within the specified VI Snippet.

aa - fetched code.png


Trusted Enthusiast
Trusted Enthusiast

I'm glad I found this.  Is there anything super-secret that requires locked Block Diagrams?

You're entirely bonkers. But I'll tell you a secret. All the best people are. ~ Alice
For he does not know what will happen; So who can tell him when it will occur? Eccl. 8:7


Hi Simon,

I just tried to use it for LabVIEW 2013 but it apparently didn't do anything. As I digged into the VIs. I identified the source of error:

The Datasocket gave the following error:

"Error 1181 occurred at DataSocket Read in Download and>Fetch>QuickDrop Launch>QuickDrop Launch

Possible reason(s):

LabVIEW:  Protocol not recognized by LabVIEW."

Do you have any guess what could be done to correct it? I really would like to use this plugin.


Hi again,

I think I debugged the problem: It is because the https protocol is not known by the Datasocket. I tried your plugin for a http link and it worked.

I tried this one:

I also tried to change https to http in the link that doesn't work, and the modified link ( although with a warning, but) worked.

The original link:

The modified link: