Advanced Plotting Toolkit

Showing results for 
Search instead for 
Did you mean: 

Runtime Error and Build Error

Perhaps someone out there, preferably authors of the Plotting Toolkit, can answer.

My first usage of the toolkit was disappointing.  I ran into two show stoppers, which I have no idea how to fix.

1) Runtime Error:

Error 402901

Could not allocate memory for image [plotserv.api_core 157]

2) Build Error:

Error 1 occurred at

Please see screen shots in attached Powerpoint file.  There are four screen grabs:

1) Error documentation for 402901 from the toolkit. "If you see this error, please contact us so we can investigate".  This is me contacting you.  I don't know how else to contact you, but through this forum.  Your website has no "Contact Us" feature.

2) Screen shot of my relevant code that uses the toolkit.  Notice call to Close VI.  Error is generated in call to View VI.

3) Screen shot of probe of error cluster.

4) Screen shot of build error.

There seems to be a memory leak in the toolkit that caused the first problem.  I'm calling the Close VI after each plot.  Have no idea why this is happening.

The second problem is that I can't build the executable, I get an error.  When I remove the call to the toolkit VIs, the problem goes away.  Thus there's some mysterious problem with the toolkit that prevents building of executables.

Either of these problems makes the toolkit unusable for me.  I am not a LabVIEW wizard where I can pull a solution out of the air.  I just expect stuff to work, as advertised.

I'd appreciate any comments that get me to a solution.  Thanks.

0 Kudos
Message 1 of 9

Well, it looks like I'm not going to get my problem solved by the authors of the plotting toolkit.  Heliosphere Research LLC voluntarily dissolved on 07 Oct 2015.

Serves me right for expecting a free toolkit to work...

Message 2 of 9

Scott, that is to bad indeed. It is a beautiful toolkit. Have you found a replacement?

0 Kudos
Message 3 of 9

My solution is based on using a very nice open source language, GLE to create high quality graphs and plots from LabVIEW. GLE can provide real vector graphic quality too. I put together a simple example front end for LabVIEW:


Actually the more cool thing would be to call GLE functions directly via a DLL for example, in my simple example i only use the command line method...


0 Kudos
Message 4 of 9

I know this is an old thread, but I'm running into the same exact issue "Could not allocate memory for image". 


I'm trying to plot a large amount of data, but it works just fine in my very rudimentary python code that also uses matplotlib (which is the basis for this toolkit). I know it's a longshot but does anyone have a workaround for this? I'd love to be able to integrate some matplotlib functionality into my LabVIEW programs and this seemed like a promising way to do that but now I'm not so sure. 

0 Kudos
Message 5 of 9

Maybe you can just use the python node within Labview to run your python code.



0 Kudos
Message 6 of 9

I'd love to do that, but for reasons outside of my control I'm stuck on LabVIEW 2016, which doesn't have the python node. Thank you for the suggestion though!

0 Kudos
Message 7 of 9

If you are stuck on 2016 perhaps you can use LabPython -


Again, its an older toolkit (now unsupported) to call matplotlib, but might get you what you want.



0 Kudos
Message 8 of 9

Thanks, I wasn't aware that existed. Think I will give it a try. 


I've managed to get the toolkit to kind of work. I've increased the timeout for the TCP reads in "" to 60 seconds. In the "Save Plot To Disk" vi I also clear all errors coming out of the IPC Call Direct VI. Then once I close the plot reference I check the size of the created file and if it's below 100 bytes I do the whole process over again. Doing all this made it work about 80% of the time. 


It's pretty janky but it works better now. Anyone trying this toolkit should be aware that it may not be a simple "plug and play" if you're trying to plot more than a small amount of data. 

0 Kudos
Message 9 of 9