Re: First impressions

   I've been working a bit with the Voice Recorder example project and a program of mine based on that one.  There are a few things I've noticed.

   The Voice Recorder RT VI has a bug in it.  After running it once and quitting, the "End?" Boolean remains True.  The next time you run it, the Network Streams loop quits right away, and the Host program never gets any data.  It needs a local to init the "End?" button false at the beginning.

   I tried to beef up this example and send four channels of data up to the host - two of the original audio and two of filtered data.  The system became very unstable.  If I drop the sampling rate down to 2k, instead of the original 8k, it works alright.  But even 4k (which should be sending the same amount of data as the 8k 2 channel original program) bogs it down.  It gets very hard to debug, since the RT disconnects without any errors or explanations.  I'm pretty sure, though, that it is a combination of network overload and CPU overload, handling the extra array manipulation.  I can get somewhat similar behavior with the Voice Recorder example program by increasing the sample rate, but it doesn't fall apart until you hit 20k, which is a factor of two above nominal, whereas my program crashes at the same nominal data throughput (4k but twice as many channels).  Hence I think that my additional array manipulation contributes.

   The weird part is that my program sometimes crashes and disconnects before I even start the host.  For example, I run it, it crashes.  I cycle power on the MyRIO and stop all program.  Wait for it to boot.  Run the RT.  It disconnects immediately, even though I haven't run the host, and hence the Network Stream isn't even active.  Bizarre.

   All that is pretty specific to my app.  If I can't resolve it acceptably, I'll have to send it in for help.  But one thing that could help in the meantime is the Distributed Systems Manager.  The MyRIO target shows up, but the contents are empty.  No data, no connection, no CPU loading, etc.  Is this a known issue?  Perhaps the support for MyRIO in the DSM just isn't ready yet?  Or do I need to reinstall some component or do something else to get this working?

Thanks,

    DaveT

-------------------------------------------------------------
David Thomson Original Code Consulting
www.originalcode.com
National Instruments Alliance Program Member
Certified LabVIEW Architect
Certified Embedded Systems Developer
-------------------------------------------------------------
There are 10 kinds of people: those who understand binary, and those who don't.
0 Kudos
(2,777 Views)