Error 42, syncing with NI.com

I seem to be getting an error when I try and sync my LV2010 Icon Editor's glyphs with ni.com. I have tried removing all of my old glyphs, etc, to no avail.

Every time I attempt to sync, the downloading dialog appears for a short while, and then gets replaced with this error... any ideas?

icon editor sync error.png

0 Kudos
(11,178 Views)

Re: Error 42, syncing with NI.com

After a bit of poking around in Download iconlibrary files.vi, the error seems to be stemming from the code to get the zip file. The Get HTTP request vi has www.ni.com as it's server and "/zip/idnet/library/us/Icon_Library.zip" as it's relative file path but instead of getting back zip data (which then gets saved to a file, and decompressed etc) it gets the following result:

<HTML><HEAD>
<TITLE>Invalid URL</TITLE>
</HEAD><BODY>
<H1>Invalid URL</H1>
The requested URL "&#47;zip&#47;idnet&#47;library&#47;us&#47;Icon&#95;Library&#46;zip", is invalid.<p>
Reference&#32;&#35;9&#46;bec28f18&#46;1281466153&#46;cd3a662
</BODY></HTML>

Obviously this then generates an error from the read ZIP file VI.. and things snowball from there.

0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

Yeah, I got the same thing on 2009. I think at the time I just worked around it by manually updating the file.

Thomas, any idea about this?


___________________
Try to take over the world!
0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

My interim hack was to replace the "get file from http" VIs with those from the internet toolkit... now it's working again for me at least. 

0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

The URL of the ZIP file is requested from ni.com with a unique code. I am gonna take a look at it asap.

http://www.newgistics.com
0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

Hi Thomas,

Here's a snippet of my hacked-and-now-working version:

hacked download that works.png

note: the get url function seems to be working correctly, it looks like it's just the way in which the GET HTTP.vi is resolving it

0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

Thanks Shaun!
The question is though, why doesn't it work any more? It used to work in the past, right?

http://www.newgistics.com
0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

I cant remember… It never worked in 2010 for me before the fix, I’ll have a look at ’09 when I get the chance.

0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

I just run it in 2010 and it works perfectly fine on my side.

Is there any proxy servers configured? If so, that might be the reason why the HTTP request fails. I'll file a CAR to myself.

http://www.newgistics.com
0 Kudos
(2,981 Views)

Re: Error 42, syncing with NI.com

There’s no proxy server here – just a wireless network to a Verizon DSL connection.

0 Kudos
(2,981 Views)