Solved!

libnipalu.so failed to initialize error for all NI related commands

Dear friends,

Already, I’ve installed two DAQ cards on PCI slots of a computer with a Centos 6.9 32-bit operating systems with the kernel version 2.6.32-754.2.1.el6.i686. The first one is PCI-6225 and the second is PCI-6509. I’ve followed all the steps of the instruction to update the Kernel and install the DAQmx802f0.iso driver successfully. However, now when I try to execute a command to verify the installation I just receive some errors. In more detail, I’ll elaborate on this issue as follows:

[user@localhost ~]$ nilsdev
libnipalu.so failed to initialize
Perhaps you need to run updateNIDrivers
Aborted



Unfortunately, I've run updateNIDrivers and it has been executed successfully, the problem isn't solved though.

Here are some outputs of NI routine commands:

 

[user@localhost ~]$ lsmod | grep ni
nikal                  55889  0 
[user@localhost ~]$ /etc/init.d/nipal start
/etc/init.d/nipal: line 81: /tmp/nipalk-load.log: Permission denied
FATAL: Error inserting nipalk (/lib/modules/2.6.32-754.2.1.el6.i686/kernel/natinst/nipal/nipalk.ko): Kernel does not have module support
 
error: nipalk failed to load
possible causes: 
   nipalk was not versioned for this kernel (2.6.32-754.2.1.el6.i686)
   modules are not enabled for this kernel (CONFIG_MODULES)
   unresolved symbols
possible solution: 
   if you recently installed a new kernel or have rebooted to
   a different kernel from one you were previously running then run
   /usr/local/bin/updateNIDrivers
   to version your NI drivers for kernel 2.6.32-754.2.1.el6.i686



Please help me to resolve this problem.

0 Kudos
(1,675 Views)