Installing NI-488.2 on Redhat 7.5

I'm trying to get set up to use my NI GPIB-USB on my Redhat 7.5 laptop. The laptop was purchased strictly for this purpose.

 

I followed all of these instructions to install the NI Linux Drivers here:

http://www.ni.com/download/ni-linux-device-drivers-2018/7664/en/

http://www.ni.com/product-documentation/54754/en/

And everything seemed to install nicely. I just went ahead and tried installing all the drivers and rebooted.

 

But I can't start gpibexplorer. When I try I get a pop-up window saying:
"The attempted operation failed. libnipalu.so failed to initialize. Verify that nipalk.ko is built and loaded." Similar thing when I try to run visaconf.

I gathered that nipal needs to load the drivers. There are no ni drivers coming up in lsmod. So I ran:
[radio@toucan ~]$ sudo /etc/init.d/nipal start
modprobe: ERROR: could not insert 'nipalk': Required key not available

error: nipalk failed to load
error: Consult the product documentation for support
error: Or search for solutions on ni.com.

What is the required key that I need? I can't figure out how to run updateNIDrivers. Any other ideas?

 

0 Kudos
(1,286 Views)