Re: 64bit libvisa.so etc - under consideration?


@Alisha_P

Our 488.2 driver cannot currently support USB GPIB devices on certain Linux kernels due to some changes in the licensing for the underlying USB driver.

Yes, those things happen, if some hw vendor refuses to tell us how to use (talk to) their devices and doesn't want to play by the rules. The Linux USB subsystem is gpl-only. I really wish, the whole kernel would be that way.

 

This seems to match what you're experiencing except that I would expect you to be able to install the software and use the GPIB-USB device on the older kernel.

Asking users to install an ancient kernel is just insane. (and in many cases doesn't even work).

Linux Embedded / Kernel Hacker / BSP / Driver development / Systems engineering
0 Kudos
(618 Views)