LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 0xc0000018 when trying install DAQmx 16.1.0

Hello,

I am attempting to install the DAQmx 16.1.0 drivers onto my Windows 10 desktop running Labview 2016. If I click to install the download, I get an error that reads :

The application was unable to start correctly (0xc0000018). Click OK to close the application.

I have tried running the program as administrator, but then it brings up the " do you want this program to make changes to your device" message, I hit yes, then it goes away and the cursor turns for second and then nothing happens.

I'd like to know what I can do to install DAQmx drivers. I have also reinstalled Labview to no avail. In another thread someone said they used the update service to install it, but I see no way in which I can install the drivers through that service. Any help would be appreciated.

 

Thanks

0 Kudos
Message 1 of 10
(3,050 Views)

Have you tried downloading a different version of NI-DAQmx such as 16.0.0? It is also compatible with your Operating System and version of LabVIEW. (http://www.ni.com/download/ni-daqmx-16.0/6120/en/)

*Just run the NI Downloader .EXE file*

 

Also, the NI Update Service would be the typical way to workaround this but it will only show a new version of NI-DAQmx if you have used previous versions of NI-DAQmx on your machine before. 

 

 

0 Kudos
Message 2 of 10
(3,008 Views)

Thanks for your response. I tried downloading the 16.0.0 version and it still provides the same error message.

0 Kudos
Message 3 of 10
(2,977 Views)

Try the following steps:

  1. Press Win+R and type regedit
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\­Microsoft\WindowsNT\CurrentVersion\Windo­­ws
  3. Than search for APPINIT_DLLS and delete the default value
  4. Reboot

I found a forum where this worked for another user.

0 Kudos
Message 4 of 10
(2,960 Views)

I'm running Windows 10 and the latest version of LabView 2016 and I was getting your same error with 16.1 and 16.0, but the version before those two (15.5.1) worked. After installing DAQmx 15.5.1 the DAQ Assistant was present instead of there being the blank spot.

0 Kudos
Message 5 of 10
(2,940 Views)

My mistake, I saw the wrong icon. The DAQ Assistant is still missing after installing DAQmx 15.5.1, sorry about that.

0 Kudos
Message 6 of 10
(2,934 Views)

Solved it - installed 15.5.1, then checked for updates through LabView's help menu and selected 16.0.0, now that driver was able to install correctly and the DAQ Assistant is present. 

0 Kudos
Message 7 of 10
(2,921 Views)

Thank you for your efforts on all fronts!

Tom

0 Kudos
Message 8 of 10
(2,852 Views)

Thanks so  much!!! it worked for me!

0 Kudos
Message 9 of 10
(2,180 Views)

Another option which worked for me with 16.1.0. I just opened the exe using 7zip and extracted the files then run the setup.exe directly from there and it worked fine. (windows 10)

0 Kudos
Message 10 of 10
(1,878 Views)