Wireless Sensor Networks

cancel
Showing results for 
Search instead for 
Did you mean: 

NI 9792 Configuration error

Solved!
Go to solution
Highlighted

Hi,
I am new member on these forums, I need help with the NI 9792 gateway configuration.
First, my gateway powered and not in secure mode, the status LED blinks twice, I read the technical sheet that implies that the gateway software has an error. No how to fix the error.
I managed to configure the gateway IP address but the device is not recognized on remote systems. For these tests I am using the Ethernet port 1.

If someone could please help me with this problem. 

Thanks for your attention.

 

0 Kudos
Message 1 of 5
(4,640 Views)
Solution
Accepted by topic author FcoA
08-27-2015 04:09 PM

Hello There;

 

So the NI 9792 is an Remote Controller; it is blinking twice because there is no software installed in the system., I would recommend you to format it, set a static ip adress and then to install the appropiate software. Remember that when you change the IP adress your PC has to be in the same subnet as the RT device and that you should connect it using a crossover cable.

 

In order to start using it you have to follow this process:

 

0.Make sure you have installed LabVIEW, LabVIEW RT, NI WSN in your computer

 

1. Ensure that all DIP switches on your CompactRIO controller are in the OFF position.

For DIP switches that toggle from left to right, move the switch to the side labeled OFF.

 

2. Disable secondary network interfaces, such as the wireless access card on a laptop and disable your firewall

 

3. Set the dip switches; Safe Mode, IP Reset and No App to the ON Possition and restart the device

 

4. Expand remote systems

 

5. Right click the NI  9792 and select Format Disk. This will set the IP to 0.0.0.0 and will format the entire system, it may take a few minutes untill you see it again under Devices and interfaces.

 

6. Change the Device's IP adress to static and change te PCs IP adress to get on the same network. (Control Panel>>Network & Sharing Center>>Local  Area Connection>>Properties>>Internet Protocol Version 4>>Properties>>Set an IP Adress and subnet.) Don't forget to set all dip switches to OFF

 

7. Install software. Expand the CompactRIO item under Remote Systems, right-click on the Software item, and select Add/Remove Software. Under the desired LabVIEW Real-Time version, select the NI-RIO set currently installed in the development computer.Select the software set add-ons you want to install. NI Scan Engine support can be selected from this menu.

 

There is a guide for the cRIO here, it works exactly the same

 

Good luck

 

0 Kudos
Message 2 of 5
(4,622 Views)

Hello,
Thanks for your solution, and I could set my gateway, change the IP address and it worked. If you could help me with another problem, maybe I miss something configuring, when I add a node NI WSN-3202, follow the steps in the data sheet GETTING STARTED GUIDE NI Wireless Sensor Network Devices, but at the time the node is already recognized in NI MAX node LEDs start blinking and then go off. I want to know if that is normal.
Thanks for your attention.

0 Kudos
Message 3 of 5
(4,584 Views)

Hey;

 

It is a perfectly normal behaviour... they turn off to save battery; even with the leds off, the node still transmits information

The important thing is that you can still see them in MAX or that the value updates in LabVIEW

 

 

Cheers

0 Kudos
Message 4 of 5
(4,581 Views)

Hello,
Thanks again for your help. I could already receive values in a LabVIEW VI. Now I am sure my WSN is working properly.
Thanks for your attention

0 Kudos
Message 5 of 5
(4,574 Views)