Volume License Manager and Automated Software Installation

cancel
Showing results for 
Search instead for 
Did you mean: 

lmgrd.exe vulnerability

Hello all , my server works fine (volume license manager v 3.2)

I need to update Flexnet Publisher from 11.5 to 11.6. It is marked as a vulnerability and I need to mitigate this ASAP. 

The only support article I found has old packages http://www.ni.com/tutorial/6032/en/ 

 

I tried to replace the old  lmgrd.exe (11.5) with an 11.6 version I got from Matlab. It did not work  

A candid question: I started working on this problem this week - is it National Instruments who has to provide the updates or LabView and Multisim, the software where I have subscriptions ? 

 

Log starts 

======================================

9:08:14 (lmgrd) FlexNet Licensing (v11.15.0.0 build 215548 i86_n3) started on <Licensing server> (IBM PC) (9/19/2019)
9:08:14 (lmgrd) Copyright (c) 1988-2017 Flexera Software LLC. All Rights Reserved.
9:08:14 (lmgrd) World Wide Web: http://www.flexerasoftware.com
9:08:14 (lmgrd) License file(s): C:\ProgramData\National Instruments\Volume License Manager\nivlm.lic 

....

9:08:14 (lmgrd) Starting vendor daemons ...
9:08:14 (lmgrd) Started nilm (pid 5332)
9:08:14 (nilm) FlexNet Licensing version v11.15.0.0 build 215548 i86_n3
9:08:14 (nilm) SLOG: Summary LOG statistics is enabled.

 

0 Kudos
Message 1 of 3
(203 Views)
Highlighted

Hi BenYuly,

 

I think I may not be understanding your question, and LabVIEW and Multisim are both owned by NI. However, National Instruments provides updates to our licensing deamon (nilm.exe), but not the license manager deamon (lmgrd.exe), which is created by Flexera Software. As I understand it, we currently do not have a new version of the licensing deamon that is compatible with version 11.6; 11.5 is the latest we are working with.

 

Can you give a bit more information about that vulnerability and where you're seeing that? That may be helpful information for our R&D teams.

Claire C.
Technical Support Engineering
National Instruments
CLD|CTD
0 Kudos
Message 2 of 3
(104 Views)

Dear Claire,

 

Thanks for your response. The problem is, 11.5 has a security vulnerability that needs to be patched. We really need the NI daemon to be compatible with the latest version to be secure.

Is there an ETA for compatibility with the latest version?

 

Thanks!

0 Kudos
Message 3 of 3
(12 Views)