Version Conversion

cancel
Showing results for 
Search instead for 
Did you mean: 

Convert LV8.2.1 to LV2020

Solved!
Go to solution
Highlighted

I need to have the attached VI file converted to work with LabView 2020.

0 Kudos
Message 1 of 6
(186 Views)
Highlighted

Just open the VI in LabVIEW 2020.  Are you having an issue opening it?


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 6
(171 Views)
Highlighted

I can open the file just fine. When I click Run an Error -201003 occurs. It reads "Error -201003 occurred at DAQmx Create Channel (AO-Voltage-Basic).vi:187005"

 

Possible Reasons

Possible reason(s):

Device cannot be accessed. Possible causes:
Device is no longer present in the system.
Device is not powered.
Device is powered, but was temporarily without power.
Device and/or chassis driver support may have been removed.
Device is damaged.
Ensure the device is properly connected and turned on. Ensure the device and/or chassis is supported in the current version of the driver. Check the device's status in NI MAX. Turn the computer off and on again. If you suspect that the device is damaged, contact National Instruments at ni.com/support.

Device Specified: cDAQ1Mod1

Task Name: _unnamedTask<0>

 

The device I'm using is no longer supported by the current NI DAQmx. I had to download some old drivers, but I don't know if the old drivers are compatible with LabView 2020. Are they?

0 Kudos
Message 3 of 6
(160 Views)
Highlighted

Do I need an older version of LabView since I'm using a CDAQ-9172 that requires NI-DAQmx 8.5?

0 Kudos
Message 4 of 6
(155 Views)
Solution
Accepted by jjohnstonFieldUSA

Yes.  Read.  https://www.ni.com/en-us/support/documentation/compatibility/17/devices-and-modules-no-longer-suppor...

According to that, you can use up to DAQmx 17.5.

 

Then read NI-DAQmx and LabVIEW Compatibility

According to that, the newest version of LabVIEW that supports DAQmx 17.5 is LabVIEW 2017.

0 Kudos
Message 5 of 6
(149 Views)
Highlighted

Very helpful! Thanks!

0 Kudos
Message 6 of 6
(146 Views)