VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

WebDAV Dialog on Deploy

Hi all,

 

ever since I've updated one of our test benches from VS 2011 to 2015 SP1 I get a prompt to enter my webDAV User and Password whenever I deploy my project. This is rather annoying for a variety of reasons: 1) I don't even know what we use webDAV for 2) The password line does not react to [Enter] the way it's supposed to; it just makes a new line... 3) The "remember Password" checkbox does nothing it would seem. 4) I've not had to do this before.

 

Instead of the negative things I would like to focus on the positive, i.e. What can I do to get rid of the prompt? What is webDAV normally used for in VS? I didn't make a conscious decision to install this if anything I uninstalled stuff while upgrading. 

 

Any hints that point me in the right direction are much appreciated.



Remember Cunningham's Law
0 Kudos
Message 1 of 8
(3,822 Views)

(In my response I'm assuming you're deploying to an NI RT target)

 

What can I do to get rid of the prompt?

Fix the WebDAV Login: 

Man... I wish I could remember exactly what causes this. You may need to go into MAX and setup a password for the WebDAV login to the target.

 

Hopefully one of the awesome NI engineers can help us here :). 

 

Move back to FTP:

The quick and dirty solution I can think of is to just go back to FTP by manually installing it in MAX. Its deprecated but still functions. It is also not recommended (reasons below).

Capture.PNG

(picture is a bit dated, so you likely have a newer version on your machine)

 

 

 

What is webDAV normally used for in VS?

File transfer to the target. In previous versions, FTP was used, and in newer versions (2013+ iirc) NI switched to using WebDAV for file transfer in favor of FTP because it was more secure.

 

 

I didn't make a conscious decision to install this if anything I uninstalled stuff while upgrading. 

The default software install on the RT target will include WebDAV and not FTP in the version you're using. In the past it would have used FTP by default. 

Tim A.
Message 2 of 8
(3,785 Views)

Thanks a lot for your answer!

That explains it completely since we upgraded from 2011.

 

I think I have to have a password, though. When we set it up, I think we tried to assign an empty password or looked for the option to not have a password and came up empty. I'll check again this week.

 

Any other Suggestions?

BTW: That dialog should have multiple CARs written about it: Not remembering the password and getting an actual CRLF when using Enter to apply the password are just two things that come to mind.



Remember Cunningham's Law
0 Kudos
Message 3 of 8
(3,761 Views)

Have you tried the default admin user with a blank password?

Tim A.
0 Kudos
Message 4 of 8
(3,753 Views)

The save option is not working for me, did anyone find a solution? It is really annoying having to type the password + click the accept button all the time...

0 Kudos
Message 5 of 8
(3,656 Views)

Hi all,

 

There is a CAR documenting that the login screen does not save the username and password through CAR 535585. The best solution is to keep the username and password as the default admin and blank password as this is what VeriStand tries upon deployment. If that combination doesn’t work, it will then prompt you to enter it.

 

To change the login information, simply navigate to the IP Address of your RT Target in the URL bar of Internet Explorer. The icon of the lock and key on the left-hand side will allow you to update your username and password there! (you will first need to sign into the target with the current username and password).

Message 6 of 8
(3,652 Views)

Thank you for the answer.

0 Kudos
Message 7 of 8
(3,650 Views)

Even with default credentials the VeriStand will stop on login popup dialog when deploying to cRIO (just tested on VeriStand 2019 R2). Even when you configure the credentials in the configuration file... And no, the save credentials checkbox doesn't work... 😭

0 Kudos
Message 8 of 8
(2,347 Views)