Showing results for 
Search instead for 
Did you mean: 

Veristand blocks missing in Simulink

Go to solution

There are two computers that I am currently having this problem on. I have installed matlab+simulink then all my national instruments software including simulink interface toolkit anf NI Veristand 2009. I was sure to completely install matlab before installing any NI software. I have done this before with other computers and everything worked. This time however the veristand blocks are missing from simulink. One of the computers that this is happening on is 64 bit. It has 64bit matlab (I couldnt get 32bit matlab to install; according to mathworks 32bit ML running on 64bit OS is not supported but should work; See link below) and 32 bit LV. Could this be a problem? The other computer is running a 32 bit OS. I have tried completely reinstalling Veristand and the blocks are still missing. Any suggestions? Thanks in advance. 

0 Kudos
Message 1 of 4
This is running on Windows 7 BTW. I do have another machine running Windows 7 (32 bit) with all the software working correctly.
0 Kudos
Message 2 of 4
Accepted by topic author jckvt

Hello Jon VT,

It appears you might be running into two different problems.  The first being that NI VeriStand is a 32-bit process and so can only communicate with 32-bit Simulink.


Second, NI VeriStand updates certain files during installation which can sometimes be marked as read only, so it may be necessary to make the updates yourself for full functionality.  This is described in the help topic Communicating with the NI VeriStand Server.


Hope this helps,

Angela M

Staff Product Support Engineer

0 Kudos
Message 3 of 4

Thank you Angela! That was the problem. I was mistaken. Both the computers are 64 bit. I figured out how to get 32 bit matlab on the computers. It was just a matter of running the installer in the win32 folder instead of the installer in the matlab disc root.

Message 4 of 4