Showing results for 
Search instead for 
Did you mean: 

Simulink Model Compile Error - Error Locating NI Linux Real-Time 2017



I'm currently trying to compile a Simulink model in Matlab 2017b/Simulink 9.0 for VeriStand 2020 R6 but receive the below error during build:


"Setting environment for using NI Linux Real-Time 2017 64-bit tools. Error locating the NI Linux Real-Time 2017 toolchain. Confirm the C/C++ Development Tools for NI Linux Real-Time, Eclipse Edition 2017 was properly installed."


I've confirmed that C & C++ Development Tools for NI Linux Real-Time 2017, Eclipse Edition is installed and cannot see any obvious installation problems. I have also checked the version compatibility and cannot see any issues there either.


I'm also using the NIVeriStand_Linux_64.tlc target file but encounter the same issue on NIVeriStand_Linux_ARM_32.tlc too.


This Simulink model was previously used on a Pharlap operating system and hasn't been modified apart from changing the target file.


Has anyone encountered this issue before? Does VeriStand/Matlab/Eclipse need to be installed in a certain order to prevent issues?



0 Kudos
Message 1 of 4

Hello LukeO94,


You are correct that your versions are compatible. Generally, the best order of installation would be MATLAB, then VeriStand Model Framework and Eclipse. The important aspect to that order really is MATLAB first before the VeriStand Model Framework, although you can work around that by manually adding the path. However, I don't think order of installation is the issue here.


You mention that this same model was compiled and used successfully on Phar Lap. Are you still able to compile this model for Windows or Phar Lap on this particular computer? I ask because that could point to a corrupt installation or some IT policy that is blocking reading of registry keys or setting environment variables. If you are able to compile for Windows or Phar Lap on this computer, then I believe this points to a specific issue with the NI Linux Real-Time toolchain and the Eclipse installation. For that, I would recommend checking the following:


  • Have you verified that NIPM shows "C/C++ Development Tools for NI Linux Real-Time 2017, Eclipse Edition" as installed?
  • In the registry editor, can you verify that there are keys under "HKLM\Software\WOW6432Node\National Instruments\gccToolchain\17.0"? 
  • If there are registry keys set there, can you verify that the x64Path exists on disk? By default, that should be C:\build\17.0\x64.

Beyond that, I would also check the following:

  • Trying running MATLAB as administrator
  • Are MATLAB and VeriStand Model Framework both installed in the C drive?


NI Product Owner
0 Kudos
Message 2 of 4

Hi Brian.D,


Unfortunately due to IT I do not have administrator rights by default so I cannot confirm by NIPM to check Eclipse is installed there. I can open Eclipse fine with no issues so that was my current assumption it was installed correctly.


I used a separate PC to compile the model for Pharlap which I unfortunately no longer have access to check this and I do not currently have the pre requisite software installed to compile for Pharlap.


I also cannot open Registry Editor and get the message "Registry editing has been disabled by your administrator". Maybe this is what's causing the issue? I will have to get temporary admin access and try again. I can confirm MATLAB and VeriStand Model Framework are both in the C drive.

0 Kudos
Message 3 of 4

Just a follow on from this, I did manage to (eventually) check the steps below. I could see Eclipse was installed in NIPM and I also tried a reinstall but this made no difference.


I took a screenshot of the registry editor while I had access to it, I'm not sure if any are missing but this is what was there:



I also tried running MATLAB as an administrator but was still returning the same error. I'm at a bit of a loss with this now. I've also tried different versions of MATLAB but with no luck unfortunately.

0 Kudos
Message 4 of 4