Showing results for 
Search instead for 
Did you mean: 

Error trying to import a simulink (.so) model to Veristand 2019R3

Go to solution

Hello All,

I am unable to import any models to Veristand 2019R3.  I am using Matlab 2019b and have compiled several different models, but I always get the same error messages when importing.  The first one is a .NET InvalidOperationException which says "this implementation is not part of the Windows Platform FIPS validated cryptographic algorithms."  I searched for the error and there was one thread that said FIPS can cause NI package manager to fail when installing an item, but I didn't see anything related to Veristand.  I have attached screenshots of the messages.  I have lots of experience with Labview and NI hardware, but I am new to Veristand, so not sure what could be wrong.  

Download All
0 Kudos
Message 1 of 4

I suspect VeriStand's MD5 hashing algorithm for importing models conflicts with FIPS. I am not sure if this is possible in your specific circumstance, but there is a method of disabling the FIPS algorithm check for certain applications as outlined here


I do not have FIPS enabled on a machine currently, but I believe you could create a config file named "System Explorer.exe.config" with that content, and place it next to System Explorer.exe on your machine (for VeriStand 2019 R3, I think that would be C:\Program Files (x86)\National Instruments\VeriStand 2019\System Explorer.exe). Depending on how you are importing the model (System Explorer vs. the Mapping Diagram in the new Editor), you may also need to try placing an identical config file next to VeriStand.exe.

NI Product Owner
0 Kudos
Message 2 of 4
Accepted by topic author lh845

Thanks, that partially worked.  I created the config file next to System Explorer.exe and added the line to the existing Veristand.exe.config file and I was able to import from the mapping diagram, but I still couldn't import from System Explorer.  However, when I go to system explorer and click on Signals or Parameters then I get the same error.  I am able to access signals on the mapping diagram, so I may be able to just use it that way.

0 Kudos
Message 3 of 4

Hi Brian,

I have an issue where LabVIEW crashes when I try to load the same model with the Model Toolkit. Is there some way to do the same mods to disable FIPS with LabVIEW?

0 Kudos
Message 4 of 4