VXI and VME

cancel
Showing results for 
Search instead for 
Did you mean: 

Test Panel Won't Work with PXI-6541/6542/6551 in PXI-1002

Solved!
Go to solution

Tearing my hair out trying to get Test Panel to work with system as described below:

 

PXI-1002 Chassis with PXI-8176 Controller.  Have in the three available slots (left to right) PXI-6551, PXI-6542 and PXI-6541.  They come up in NIMAX, they self test, reset, and self-calibrate.  But when I attempt to open a Test Panel, I get an Error as follows:

nidmfpan.exe - Application Error

The application failed to initialize properly (0xc0000142). Click on OK to terminate the application.

 

I have uninstalled, re-installed, modified and repaired everything from NIDAQMX (15.0.1) to HSDIO 15.0, to NI VISA (15.0.1), etc.

 

Original symptom was that when I pressed the Test Panel button, nothing would happen.  Then the next symptom was that MAX said it needed MFC90.dll (not found), and MSVCP90.dll (not found) and MSVCR90.DLL (not found).

 

I can't find any help topics or forum posts that cover this.  Very annoying.  

0 Kudos
Message 1 of 5
(6,264 Views)
Solution
Accepted by topic author TescomAustin

Hi Tescom,

 

Sorry to hear that!  Nidmfpan.exe is the process that opens MAX test panels and MFC90.dll is a Windows wrapper.  Combinations of driver reinstalls or copying of other MFC90.dll files into System32 are unlikely to resolve the issue.

 

Are you on XP?  Try navigating to C:\Windows\System32 and renaming the file nidmfpan.exe.manifest to nidmfpan.exe.manifest.back and subsequently close/reopen MAX and attempt to open a test panel.  Is it successful?

 

Note that the file to rename is nidmfpan.exe.manifest and NOT nidmfpan.exe.

 

If not immediately successful, close and reopen MAX and try out the test panels a few more times.  If after several tries it still doesn't work and the correct manifest file was changed, this may point to a deeper Windows issue that requires a reformat of the OS.

 

Really hope that does it!

 

P.S. you might get more visibility for an issue like this in either the "PXI" or "Digital I/O" sections.  VXI and VME are not very widely used these days so this section of the forums probably doesn't get too much traffic.

Michael Keane
National Instruments
Message 2 of 5
(6,238 Views)

Here's an example of this working in the past for someone:

http://forums.ni.com/t5/Multifunction-DAQ/Test-panel-will-not-start/td-p/1146751

Michael Keane
National Instruments
0 Kudos
Message 3 of 5
(6,236 Views)

That did it.  I am leaving on vacation momentarily, so just in the nick of time.  Thanks so VERY much.  We are metrologists, not programmers.  We have to have some software knowledge, but some of th NI software details get pretty interesting.  Thank you again.  It worked.  I am passing the project on to another tech.

0 Kudos
Message 4 of 5
(6,233 Views)

Thank goodness!  Great to hear, and what a good start to a vacation 🙂

Michael Keane
National Instruments
0 Kudos
Message 5 of 5
(6,229 Views)