VXI and VME

cancel
Showing results for 
Search instead for 
Did you mean: 

Resman fails in non administrator user mode NT

When I switch from Administrator/Power User to a restricted quest account resman fails to run. The error message returned is that NI-VXI fails to initialize and is unable to allocate system resouces. What do you need to change to get NI-VXI/VISA to work under a restricted user account.
0 Kudos
Message 1 of 9
(8,805 Views)
This is because Resman creates a key in the registry when it begins (HKLM\SOFTWARE\National Instruments\NI-VXI for WIN32\ResourceManagerStarted SUCCESS), assigns the value of this key to be the time and date that Resman is running ("at 4:04 PM on Tuesday, October 28"), and then deletes the key and its value when it is finished. Members of the "Users" group have read permission, but they do not have create/delete/write permission. Resman communicates no error condition when it cannot create this key.

To be able to run Resman as a normal "user", you can do the following:

1. Log on to your computer as the Admin. Go to Start >> Run and type in"regedt" (regedit32 for WIN2000/NT) to start the Registry Editor.

2.Open the Key: HKEY_LOCAL_MACHINE >>SOFTWARE>>National Instruments>>NI-VXI for Win32

3. Right click on thius folder and select "Permissions"

4. Select the "everyone" and the user account line nears the middle of the list.

5. Change the access to Full Control. Press OK and exit. Reboot your computer if needed, now you should be able to run Resman as a restricted user.
Message 2 of 9
(8,793 Views)
I changed the permission in the registry but resman still fails. The exact error message is:

"VXI Resource Manager Failed due to the following error:

Unable to initialize NI-VXI driver.
Insufficient system resources to perform necessary memory allocation"

I had to use "regedt32" (sic) to change permissions. "regedit" does not allow you to access security.

Thanks for the help.
0 Kudos
Message 3 of 9
(8,791 Views)
I found a KnowledgeBase which covers the same issue, there is a different fix besides the one I have suggested, you can try ut out and see if it works. If it still don't work, there mught be something else than the admin/user privileges that caused the problem.

http://digital.ni.com/public.nsf/websearch/B00FF8622ED65536862565AB004666DF?OpenDocument
Message 4 of 9
(8,770 Views)
You should not replace resmanguivvgl.dll (NI-VXI 3.x) with the resmangui.dll (NI-VXI 2.x) found in that KB. Only attempt that solution if you are still using NI-VXI 2.x.

I have a couple of other questions, to try and get more information on this issue, if you are using NI-VXI 3.x.

Which version of NI-VXI are you using?
What version of MAX do you have installed?

When you open MAX, does your VXI controller show up as present and enabled?
Can you run resman from within MAX?

Thank you!

--
Richard Thrapp
Staff Software Engineer
VXI Software
Message 5 of 9
(8,762 Views)
NI-VXI version 3.2
MAX version 3.1.1.3003

VXI System Slot 0 in MAX has a red X and resman will not run, same error.
0 Kudos
Message 6 of 9
(8,759 Views)
We tried to reproduce this issue but did not get the error when using a restricted user account. To help us better understand the issue, please send us the following info:

1. Confirm that you are running a NT4 system?
2. A screen shot of the exact error message from MAX
3. Export the following keys from your registry:
a) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\niVVGLk
b) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VXI
4. The VXI device's hardware configuration (exported to a file from MAX)
5. The state of the "nivvglk" driver, after you log in as the restricted user:
a) In NT4, this can be retrieved from the "Devices" list in the Control Panel. Just look for nivvglk, and let us know if it's Started or not.
b) In 2k/XP, this can be retrieved from the Device Manager in system settings. In the View menu, select "Show Hidden Devices", and select the group "Non-Plug and Play Drivers". Go to properties on nivvglk. The Driver tab will list the current status.

As for now, I recommend upgrade your VXI driver to the current NI-VXI 3.3.1 and check for any effects.
Message 7 of 9
(8,742 Views)
The attached zip file contains the information requested.

The "nivvglk" driver status is "Unavailable"

Thanks

Message Edited by hockyhubby on 04-05-2005 11:43 AM

0 Kudos
Message 8 of 9
(8,731 Views)
Here are my testing results:

First, I have trouble just to have the VXI driver loaded into the system when logged in as a restricted user. In MAX, I will see a black cross mark(not red) and "run resman" is grayed out as a result of no driver loaded.

Second, I tested the same hardware setup with NI-VXI 3.3.1 and resman could be run fine under the restricted user account, I am remember correctly, you haven't tried upgrade your driver yet. this could be the easiest solution to this issue.

Also, it looked like you have Windows2000 or XP instead of NT, or am I mistaking?

Finally, please let me know step by step on how you set up your hardware, software and restricted user account. Apparently we have seen different behaviors when logged in as a restricted user and at least you could load NI-VXI 3.2 correctly.
Message 9 of 9
(8,685 Views)