VXI and VME

cancel
Showing results for 
Search instead for 
Did you mean: 

MAX and whole comp. gets freeze when I tried to run RESMAN

Hi

I am trying to run RESMAN for VXI-MXI-2 in MAX 3.3.1, but it and the computer gets freeze and said "Searching for Statically Configured Devices" such as message 1 (attached). Then next time I tried to run it again it says "VXI locked up" I have to reset it. Please help!! Thanks in advance.
0 Kudos
Message 1 of 7
(8,948 Views)


@mfrescas wrote:
Hi

I am trying to run RESMAN for VXI-MXI-2 in MAX 3.3.1, but it and the computer gets freeze and said "Searching for Statically Configured Devices" such as message 1 (attached). Then next time I tried to run it again it says "VXI locked up" I have to reset it. Please help!! Thanks in advance.


I would like to have as well TMExplorer installation program. This was the previous program before MAX came. I could not find it at ni.com. Thanks in advance.
0 Kudos
Message 2 of 7
(8,938 Views)
This problem happens when there is no VXI Bus Timeout. The way to verify it is when the Resource Manager locks up again, turn off the chassis but leave the computer on, if the computer resumes and go back to normal, then this will be the cause of the hanging.

The fix to it is to configure the VXI-MXI Bus Timeout, since you can not use the configuration utility, try switch the Factory Overwrite dip switch, this should fix it for you. The location of the this Factory Overwrite switch can be found in the KnowledgeBase you saw before:

http://zone.ni.com/devzone/conceptd.nsf/webmain/86054DE2C9DACE7A86256CEE0070237C?opendocument

The TMExlorer only came with older versions of VXI driver and the new driver uses Measurement & Automation Explorer which covers all the functionality of the old TMExlorer. By switching to the old driver will not help in this situation.
0 Kudos
Message 3 of 7
(8,929 Views)
Thanks Tong!!!,

I just check what you suggested me and it is true, if I unplugg cable or turn off VXI, Resman resumes unblocking itself. I have tried switching the Factory Overwrite dip switch in the PCI-MXI-2 since the beginning of the problem, but it did not work because I am having the same result, as an additional clue I checked Bus Timeout and it is at 128ms. I still suspect the problem is the VXI-MXI-2 controller, what do you think??
0 Kudos
Message 4 of 7
(8,916 Views)
There are two bus timeouts: one for MXI bus and the other for VXI bus, 128ms seems too long for the VXI bus timeout, it should be around 500 us for most VXI bus settings. If your VXI bus timeout is 128 ms, then it will probably take over a minute for Resman to finish running, are you sure that the whole computer locked up, not just Resman?

There are also two factory overwrite dip switches also: one on the VXI-MXI controller and the other on the PCI-MXI card, we want to switch the one on the VXI-MXI controller.
0 Kudos
Message 5 of 7
(8,909 Views)
Thanks Tong,

I replaced VXI-MXI-2 and Resman is working just fine. Problem was the card directly.

Regards!!!!
0 Kudos
Message 6 of 7
(8,904 Views)

I found a similar problem that was solved by exchanging both ends in the MXI-2 cable:

http://forums.ni.com/t5/VXI-and-VME/Computer-freezes-when-running-RESMAN-with-VME-crate-powered-down...

0 Kudos
Message 7 of 7
(6,543 Views)