VI Analyzer Enthusiasts Documents

cancel
Showing results for 
Search instead for 
Did you mean: 

Using the VI Analyzer Toolkit with 64-bit LabVIEW

NOTE: The information on this page only pertains to LabVIEW 2015 64-bit and earlier. The VI Analyzer Toolkit is fully supported (including installers) for 64-bit LabVIEW on Windows, Mac, and Linux, with LabVIEW 2016 64-bit and later.

The VI Analyzer Toolkit installer for LabVIEW 2015 and previous only works with a 32-bit LabVIEW installation.  The following steps (valid for LabVIEW 2009 through LabVIEW 2015) allow you to manually install the VI Analyzer Toolkit to 64-bit LabVIEW.  These steps assume you have a valid license for LabVIEW 32-bit, LabVIEW 64-bit, and the VI Analyzer Toolkit.

Note - This procedure has not been formally tested by National Instruments, and thus is not officially supported.  If you have any issues following these steps, please post them in the comments thread on this document, and not on the NI support forums.

  1. Ensure LabVIEW 32-bit and LabVIEW 64-bit are already installed.  They must be the same version.
  2. Ensure the VI Analyzer Toolkit (same version) is installed to LabVIEW 32-bit.
  3. Ensure you have properly activated your VI Analyzer Toolkit license.
  4. Copy the following files and folders from your LabVIEW 32-bit folder to your LabVIEW 64-bit folder:
    • examples\VIAnalyzer (the folder is examples\VI Analyzer Toolkit in LabVIEW 2014 and 2015)
    • help\lvvianalyzer.chm
    • manuals\VIAnalyzer_User_Guide.pdf
    • menus\Categories\Programming\_VIAnalyzerTK
    • menus\Categories\Programming\_VIAnalyzerTK.mnu
    • project\_VI Analyzer\_tests
    • project\_VI Analyzer\testcreator.llb
    • project\errors\VI-Analyzer-errors.txt
    • readme\readme_VIAn.html
    • resource\Framework\Providers\VI_Analyzer_Toolkit
    • resource\Framework\Providers\GProviders\VI_Analyzer_Toolkit.ini (only present in LabVIEW 2011 through LabVIEW 2015)
    • vi.lib\addons\analyzer\analyzerapi.llb
    • vi.lib\addons\analyzer\NI_VIAnalyzerTKVIs.lvlib
  5. Mass compile the following folders in LabVIEW 64-bit:
    • examples\VIAnalyzer
    • project\_VI Analyzer
    • resource\Framework\Providers\VI_Analyzer_Toolkit
    • vi.lib\addons\analyzer

Once you have followed these steps, you should be able to use the VI Analyzer Toolkit in LabVIEW 64-bit. If, however, you encounter a licensing error when opening VI Analyzer VIs in 64-bit LabVIEW, you may need to follow these additional steps:

Fixing Licensing Issue with VI Analyzer Toolkit and 64-bit LabVIEW

  1. Since these steps involve modifying the Windows registry, ensure your system is backed up appropriately.
  2. Download the attached vian_64bit.zip file. Make sure to extract the contents to a folder on disk. Running the registry files from within the zip file may not work correctly.
  3. If your 64-bit LabVIEW is installed in the default location (C:\Program Files\National Instruments), skip to step 5.
  4. If your 64-bit LabVIEW is installed in a non-default location, use a program like Notepad to modify the .reg file that matches your LabVIEW version to correct the two "InstallDir" entries in the .reg file to point to your custom LabVIEW install location. Note that double backslashes are used for path separators. Save your edits to the .reg file.
  5. Double-click on the .reg file that matches your LabVIEW version to update your registry. This should solve the licensing errors when opening VI Analyzer VIs in 64-bit LabVIEW.
DNatt, LV R&D
Comments
Member D*
Member

I was able to copy the files, but I get a license error when I try to use them in LV2013 SP1 64-bit.

I am able to use 32-bit LV2013 SP1, and also 32- & 64-bit versions of LV 2012-2010 without a problem.

Example Gatekeeper
Example Gatekeeper

I have LabVIEW 2013 SP1 32-bit and 64-bit installed on my system, and the licenses for LabVIEW and the VI Analyzer Toolkit look fine:

lic.png

I followed the steps in this document exactly, and the VI Analyzer Toolkit (both the API and the UI) work fine in LabVIEW 2013 SP1 64-bit. I'm not sure what the problem could be on your system.

DNatt, LV R&D
Example Gatekeeper
Example Gatekeeper

We were able to solve D*'s issue with some modifications to his registry. I have added the steps required for this modification to the main document.

DNatt, LV R&D
Active Participant Enrico_Segre
Active Participant

Tried and succeeded with LV2015SP1, Ubuntu 14.04.

For convenience, this is a script for doing the copying part of 4. above, from shell (sudo).

#!/bin/bash

SOURCE32=/usr/local/natinst/LabVIEW-2015

TARGET64=/usr/local/natinst/LabVIEW-2015-64

for f in \

    "examples/VI Analyzer Toolkit/" \

    "help/lvvian_f.bin" \

    "help/lvvian_t.bin" \

    "help/lvvian_w.bin" \

    "manuals/VIAnalyzer_User_Guide.pdf" \

    "menus/Categories/Programming/_VIAnalyzerTK" \

    "menus/Categories/Programming/_VIAnalyzerTK.mnu" \

    "project/_VI Analyzer/_tests/" \

    "project/_VI Analyzer/testcreator.llb" \

    "project/errors/" \

    "readme/readme_VIAn.html" \

    "resource/Framework/Providers/VI_Analyzer_Toolkit/" \

    "resource/Framework/Providers/GProviders/VI_Analyzer_Toolkit.ini" \

    "vi.lib/addons/analyzer/analyzerapi.llb" \

    "vi.lib/addons/analyzer/NI_VIAnalyzerTKVIs.lvlib"

do

    cp -rf "$SOURCE32/$f" "$TARGET64/$f"

done

Example Gatekeeper
Example Gatekeeper

Thanks Enrico for posting this helpful information for Linux VI Analyzer users!

DNatt, LV R&D
Active Participant Evan
Active Participant

Hey all, this tripped me up.  I ran the registry fix right from the RAR file in a temp folder (didn't save it just opened it from firefox).  Though windows said it applied it, it never put the keys in the registry.  Saving the file I needed to the desktop and then running it actually added the keys and the analyzer works.

Example Gatekeeper
Example Gatekeeper

Thanks Evan, I have updated the instructions to mention explicitly unzipping the files before using them.

DNatt, LV R&D
Member DDTun
Member

I have followed the instructions and double checked everything, but when I run the VI analyzer the list of tests is missing?

Example Gatekeeper
Example Gatekeeper

DDTun, I don't know what the problem could be. Carefully following these instructions has worked every other time.

DNatt, LV R&D
Member DDTun
Member

Hi Darren, problem was fixed by installing 2016 version, thanks anyway.

Contributors