Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

Unable To Talk to Power Meter Via GPIB

Hello all.

I have Labview 2016 installed. NI Max installed. I am using a Agilent 82357B USB to GPIB converter. I have only 1 device on the GPIB interface. It is an Agilent E4418 power meter.

When I installed the Agilent/Keysight IO library, I specifically set it to be the Secondary option on the bus.

NI Max sees:
ASRL1::INSTR "COM1"

ASRL3::INSTR "COM3"

and the GPIB interface and power meter (GPIB address 13) as GPIB0::13:INSTR "Power Meter."

If I open the VISA Test Panel, and select IO Control, I can send a "*IDN?" query and get the appropriate response.

HOWEVER, if I drag GPIB0::13:INSTR in to a VI, and select 'Refresh', I no longer see the interface.

Anybody know why I cannot see the interface in Labview?

Thanks,

-Shawn

0 Kudos
Message 1 of 4
(2,664 Views)
3 REPLIES

Re: Unable To Talk to Power Peter Via GPIB

Hi Shawn,

Where do you work in SLC?  I can come by for an hour or so and see if I can help you get up and running.  My email is bryan@endigit.com.  Can you send me your contact info and we can set up a time for me to come help?

 

Bryan Heslop

Endigit

0 Kudos
Message 2 of 4
(2,631 Views)

Re: Unable To Talk to Power Meter Via GPIB

All,

Bryan was able to help me out. The "problem" (as I understand it) was that in LabView the Agilent GPIB interface was actually being used and addressed as a VISA interface.

Once we used the Instrument IO | VISA writes and reads (instead of the GPIB commands) I was able to communicate with the instrument.

Until yesterday...

I am doing the self instruction lessons that NI offers. I'm in Lesson 8 now. In this lesson, you open NI Max and install the DAQMx suite. Then you select the NI PCI-6225 as an instrument.

I completed that lesson and tried to talk to my power meter at GPIB address 13.

I am unable to communicate via GPIB.

I think the reason is NI Max has now moved my GPIB0::INTFC to "? Miscellaneous VISA Resource"

As a result, in a VI, the GPIB port is no longer seen as an interface.

Does anybody have any idea how to get my GPIB interface back in to a VI?

Screenshots are attached.

Thanks,

-Shawn

 

0 Kudos
Message 3 of 4
(2,497 Views)

Re: Unable To Talk to Power Meter Via GPIB

Disregard.

I figured it out. The problem was I powered down the power meter, then rebooted the PC.

Once the PC came up, I ran NI Max with the power meter still turned off.

Later, I turned on the power meter, refreshed several times and never saw the power meter.

I took a break from it and left the power meter on. I woke up the PC, restarted NI Max, and my power meter appeared in Devices and Interfaces as it did before.

Tip: Make sure your instruments are powered on before running NI Max.

I hope it helps someone else,

-Shawn

0 Kudos
Message 4 of 4
(2,493 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.