USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

stop and restart the USRP

Hello,

 

I have been trying to implement a small application for reception and analysis of radio signals. Well, I want to be able to stop and restart the record at wish. The first operation works fine; I can record and stop. However, when I try to record again, I get an error : "This operation requires the driver to be in the Running state". Although when stop recording it goes to initialize state (starting point) where it first started and worked properly. I've attached my VI to this thread.

 

kind regards

0 Kudos
Message 1 of 5
(3,453 Views)

Hi,

 

I took a look at your VI and reproduced the problem in your VI but I tried to simplify the problem by trying to reproduce it in a smaller VI (attached).

Please find the VI attached which starts aborts and restarts a acquisition with configuration stages in between. I could not reproduce the issue using the VI which I have attached.

So I think there might be some very small issue in the VI which you posted.

Thanks.

 

Note: I used driver 14.0 which was recently released. Please ignore any driver specific VIs or connections.

0 Kudos
Message 2 of 5
(3,438 Views)

Also one more thing to consider is whether the initialize call happens only once after you hit record once again. (Time between you hit ok on the button and when you hit record ).

0 Kudos
Message 3 of 5
(3,430 Views)

Hi Aristocrate,

 

could you already solve your problem?

 

 

Best Regards,

Andi

0 Kudos
Message 4 of 5
(3,356 Views)

sorry that I didn't reply instanteneously after you posted many suggestion to my thread. I could actually solve the matter after I initiated this thread. Attached my solution to my own problem. The previous couldn't work because of others state which was pulled in the queue after a "stop record" case was triggered. Thanks you all for your suggestions.

0 Kudos
Message 5 of 5
(3,318 Views)