USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

Why chirp signal does not appear to oscilloscope and spectrum analyzer

Solved!
Go to solution

Hi all,

 

I am trying to generate chirp signal with parameters as shown in Figure "LFM.jpg" and block diagram as shows in Figure "bellaa.jpg." I used 2 frequencies at SISO system with frequency RF = freq 1 + freq 2. When i run my project, the appearance of chirp signal was succesful. But, while i am trying to appear it to oscilloscope and spectrum analyzer, it did not work. There was no appearance of signal.

 

Does anyone know what the problem happen and how how to solve it?

Thanks

0 Kudos
Message 1 of 6
(1,299 Views)

Hi Bellaaa,

 

I’m a little concerned about the coerced carrier frequency being 100K. What USRP are you using?

 

Have you tried the test in loop-back (sending the signal to an RX line on the USRP) and running an RX example as well as the TX example?

 

Also, how do you have the spectrum analyzer hooked up to the USRP?

0 Kudos
Message 2 of 6
(1,233 Views)

 Hi Matt,

 

I used N210 and NI-2922.

 

I have tried to test it in loop-back. And They run well. I have attached two figures to show you. I hope it appropriate with your meaning.

 

I used SMA cable to connect SA and USRP (One is connected to RF channel 1 port at USRP, another is connected to channel 1 port at spectrum analyzer)

 

Do you think that the carrier frequency in LabVIEW is unable in Spectrum Analyzer ? I mean that the carrier frequency in LabVIEW is not in a frequency range of Spectrum Analyzer.

0 Kudos
Message 3 of 6
(1,222 Views)

Hi Bellaaa,

 

I’m glad to hear that the test worked in loop back. This shows that the software and USRP are good. Also, the why you have the USRP hooked up to the SA sounds correct.

 

I’m not sure what the frequency range of the SA is or how that should be configured. Have you checked to user manual for the SA that you have to make sure that it’s appropriate for the test you’re trying to run?

0 Kudos
Message 4 of 6
(1,196 Views)

Hi Matt,

 

I didn't check the user manual for the SA yet. But, i would check it later. Thanks for your suggestion.

 

But, i am in a doubt that the received signal is correct. It looked a modulated signal, not FMCW. Do you think so ?

 

When i have tried to change the IQ rate value of 20 MHz to fulfill the nyquist requirement or 2 times of max tone frequency (in this case, 10 MHz), but the overflow of write data Tx was happen. Why i got this error ?

 

 

 

 

0 Kudos
Message 5 of 6
(1,172 Views)
Solution
Accepted by topic author bellaaa

Hi Bellaaa,

 

 

Regarding the overflow error, this is mostly related to how quickly you write data to the USRP, as well as the USRP itself.

 

When the USRP device is initialized and a generation started, the sample clock of the USRP will continuously run at the rate specified. 


For example, let us say that you have specified an IQ Rate of 20MHz. At this rate, 20*10^6 samples will be removed from the USRP buffer every second. 

 

If the host application writes to the USRP 40*10^6 samples every second, then the generation will not be able to keep up, and the buffer will overflow. If you were to write to the USRP 10*10^6 samples every second, then the generation will occur faster than you are providing samples, which would result in underflow. 

 

This was also discussed on this forum post.

 

 

Please let me know if this helps!
Stephen 

0 Kudos
Message 6 of 6
(1,162 Views)