USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

Fail to Connect USRP 2920 to My PC

Hello all,

 

Maybe this is a basic question but I've been searching for the solution for a long time. Thanks in advance for helping me. Here is my situation:

I'm using one laptop connection method to connect two USRP 2920 with MIMO cable. When I plug ethernet cable into my laptop, no LED light of the ethernet port on USRP is on.

 

Methods I tried:

  • removed and connected the ethernet cable again for several times -- didn't work
  • removed and connected the power supply cables for several times -- didn't work
  • used command "uhd_find_devices" in Terminal to check the hardware connection, turned out "No UHD Devices Found"
  • tried command "ifconfig" in Terminal but it didn't show the ethernet connection
  • tried couple of ethernet configuration commands in Terminal -- didn't work

 

Previous work I did:

  • Successfully burned firmware and FPGA images into both USRPs
  • Connect to another laptop with Ubuntu 12.04 OS, it can successfully recognized; however, I have to use my laptop to finish the project.

 

My question is: is it an USRP problem or my OS ethernet setting up problem? if it is my OS problem, how to solve it?

 

My system info:

  • Using latest GNU Radio
  • OS: Ubuntu 16.04 64-bit
  • Two USRP 2920s connected by MIMO cable

 

 

 

0 Kudos
Message 1 of 3
(2,172 Views)

Hi bsun003,

 

LabVIEW is the only language supported by NI for the 2920, so there aren't very many people on these forums familiar with GNU Radio. I reccomend contacting Ettus support. They can point you to resources that will help with open source tools. 

0 Kudos
Message 2 of 3
(2,152 Views)

Hello,

 

Thanks for the advice. I'll contact them.

 

Best regards,

 

Bojun

0 Kudos
Message 3 of 3
(2,144 Views)