USRP Software Radio

cancel
Showing results for 
Search instead for 
Did you mean: 

Can NI-USRP be worked on GNU Radio?

Hi BHANU_India,

 

It is possible to use GNU Radio with an NI USRP. However, using the HW with GNU radio isn't supported by NI. I reccomend contacting Ettus support at https://www.ettus.com/support

 

0 Kudos
Message 21 of 30
(1,598 Views)

Thanks

0 Kudos
Message 22 of 30
(1,597 Views)

Is UHD needed for LabView?

0 Kudos
Message 23 of 30
(1,585 Views)

If we are installing directly UHD then why many environment are needed?

  • Microsoft Windows (7, 8, 8.1, 10)
  • Microsoft Visual Studio (2012, 2013, 2015)
  • CMake (3.4.0 or later)
  • Boost (1.56 or later)
  • LibUSB (1.0 or later)
  • Python (2.7.x)
  • Mako (0.5.0 or later)
  • Doxygen (1.8 or later, optional)
  • NSIS (2.50 or later, optional)   
  • Why those all are needed if we are installing directly UHD ?
0 Kudos
Message 24 of 30
(1,584 Views)

How to connect NI-USRP with PC by using NI-USRP configuration Utility?

0 Kudos
Message 25 of 30
(1,582 Views)

BhanuRajput_India,

 

UHD is not needed to use LabVIEW. If you are using NI USRP hardware, all you need is the NI-USRP driver and LabVIEW. If you are using Ettus hardware, there may be other steps needed first to get the hardware recognized by your computer. What hardware are you using? I recommend looking up the corresponding getting started guide to get your equpiment up and running. 

0 Kudos
Message 26 of 30
(1,570 Views)

I am using NI USRP-2920.

0 Kudos
Message 27 of 30
(1,564 Views)

Please tell me anyone exact procedure for FM implementation by using GNU Radio and NI USRP-2920 .

Secondly, by using NI USRP-2920 and LabView. 

0 Kudos
Message 28 of 30
(1,563 Views)

There aren't very many people that use GNU Radio on these forums. Most people use LabVIEW.

 

If you are using LabVIEW communications, there are several examples and guided help tutorials on how to use Frequency modulation. 

 

If you are using LabVIEW 2016, I recommend checking out the community page: https://decibel.ni.com/content/docs/DOC-40622

There are several examples there. 

0 Kudos
Message 29 of 30
(1,561 Views)
  • Microsoft Windows (7, 8, 8.1, 10)
  • Microsoft Visual Studio (2012, 2013, 2015)
  • CMake (3.4.0 or later)
  • Boost (1.56 or later)
  • LibUSB (1.0 or later)
  • Python (2.7.x)
  • Mako (0.5.0 or later)
  • Doxygen (1.8 or later, optional)
  • NSIS (2.50 or later, optional)   
  • Why those all are needed if we are installing directly UHD ? why all those needed if we are installing directly UHD latest version?
0 Kudos
Message 30 of 30
(1,554 Views)