Troubleshooting Hardware

cancel
Showing results for 
Search instead for 
Did you mean: 

roboRIO 2.0 faulty chip

Our roboRIO 2.0 chip is faulty.  The software help desk reloaded the code several time and completed diagnostics.  It worked on our WiFi at school, but would not work on the network at competition.  We currently have a loaner, but need a working roboRIO by our next competition on March 17th.  Please help!  

 

20230306_135550.jpg

0 Kudos
Message 1 of 10
(987 Views)

Hi Stevepeterson0809, thanks for posting on the forums.

I'm Matthew with NI.

 

Are you able to connect to the device over ethernet through the KoP radio? Or directly via ethernet or USB?
(Since it sounds like it was working in some cases but not others, it's likely the device is functioning properly, but some settings may be configured such that they don't work as desired at competition).

0 Kudos
Message 2 of 10
(979 Views)

Control System Advisors (CSAs) at FRC Competition in Albany, GA, told us that the firmware was continuing to erase itself.  They loaded firmware using mini-SD card, it failed several times to hold the firmware.  CSAs could not determine why it continued to drop the firmware.  It would not run via Ethernet or USB at the competition even though it ran via WiFi at our school prior.  Our loaner roboRIO works on both Ethernet, USB and WiFi right now so it is something with this particular roboRIO.  

0 Kudos
Message 3 of 10
(955 Views)

Have you tried a new SD card? Flash storage can fail after a limited number of writes to the card.

0 Kudos
Message 4 of 10
(931 Views)

Will try that.  What is the process for exchanging a faulty roboRIO with a good one?  

0 Kudos
Message 5 of 10
(917 Views)

If we're unable to diagnose and resolve the issue you're having. I'll work with you to file the RMA (or, if I'm not in the office, one of my fellow NI engineers will).

0 Kudos
Message 6 of 10
(908 Views)

We tried a new SD card and had the same problems.  RoboRio 2.0 is not processing the code or recognizing the code on the SD card.  

0 Kudos
Message 7 of 10
(897 Views)

And just to clarify, you're using the "*.img.zip" file from the "SD images" folder and are imaging the SD card using either BalenaEtcher or the Raspberry Pi imager as described here: https://docs.wpilib.org/en/stable/docs/zero-to-robot/step-3/roborio2-imaging.html ?

0 Kudos
Message 8 of 10
(892 Views)

Yes, we used BalenaEtcher with ".img.zip" file from the "SD Image" folder.  

0 Kudos
Message 9 of 10
(882 Views)

I sent you a private message on next steps.

0 Kudos
Message 10 of 10
(877 Views)