Troubleshooting Hardware

Showing results for 
Search instead for 
Did you mean: 

roboRIO 2.0 constant 3 flash orange status light in safe mode, we can not format the robot

We have done all diagnostics and met with another team to try and figure out why the RIO will not communicate. We continually get an error when imaging and the RIO flashes 3 times on status which indicates a hardware issue according to the manual. We need an RMA on the device ASAP so that we can begin programming and testing. This is our rookie year so every day counts.



0 Kudos
Message 1 of 7

We are having the same issues with two of the Rio 2.0s.  Tried all of the troubleshooting steps, nothing works.


EDITING (because "as a new user I can only post twice in 24 hours).


More information ...


So I got out our third Rio 2.0 and tried that.  On power up the status light blinks twice, I'm guessing it goes through a reboot (Windows sound for USB device change), then status is solid, then reboot again, and status light blinks three times.  Guessing it just restarted to safe mode.  The tool says that it finishes formatting, the is re-imaging, and fails after a minute or two.

0 Kudos
Message 2 of 7

Hi!, thanks for posting on the forums.


The process has changed slightly between the original roboRIO and the roboRIO 2.0 - now we "format" the controller by imaging an SD card (, the imaging tool is only needed to set the team number once this is done.


Hope this helps!

0 Kudos
Message 3 of 7

Hello! Is there a similar process for the roboRIO 1.0?

0 Kudos
Message 4 of 7

@Caro6413 wrote:

Hello! Is there a similar process for the roboRIO 1.0?

There's a USB recovery method for the original roboRIO that's done differently than this process.  If you're still seeing the flashing STATUS light, can you send me a message and I'll talk you through that?


Alternatively, you can create a new thread here to ask for help and someone will respond there.

0 Kudos
Message 5 of 7

@BoKnows  We have the constantly flashing light on the Roborio 2.0.  Is there a way to factory reset the controller?

0 Kudos
Message 6 of 7

It generally helps to create a new thread for new issues so we don't accidentally have miscommunication working between multiple issues in the same place.  


The factory reset method for roboRIO 2.0 is to add a fresh image to the SD Card:  I'd recommend using one of the third-party writing tools if you're running into issues with the roboRIO Imaging Tool.  This tool generally needs you to image the SD Card prior.


If that doesn't work, can you create a new thread so we can focus on what you're running into with that thread?

0 Kudos
Message 7 of 7