Troubleshooting Hardware

cancel
Showing results for 
Search instead for 
Did you mean: 

Team 3484 RoboRIO Bricked

We currently have two roboRIO devices that appear to be bricked/do not allow us to format or find them. We are unsure as to how best to solve this issue, as many other forum posts before have not mentioned a fix for our specific problem.

 

We have tried reformatting the device to no avail, as well as updating the firmware. The RIO simply does not allow us to do this, and provides us with the "Corrupt Firmware" error. 

 

Additionally, in NI MAX, the rio asks us for an administrator password that does not exist, and was never set by our team.

 

Any information or help would be greatly appreciated. Thank you from team 3484.

0 Kudos
Message 1 of 11
(498 Views)

For the steps you're trying in MAX, leave the password blank.  All roboRIOs have a password.  It just starts out as admin/administrator and a blank password.

 

What behavior do you see with the status LED?

0 Kudos
Message 2 of 11
(381 Views)

When MAX prompts us for a password, we are unable to press the login button unless a password is given. We cannot leave it blank. The status LED is solid.

0 Kudos
Message 3 of 11
(379 Views)

It should let you leave it blank.  Are you saying the button isn't pressable?

 

Try entering a space and deleting it to trick the button?  Though, if it's disabled I'd want to funnel that feedback to our MAX team.  All RIO devices have a default blank password.

0 Kudos
Message 4 of 11
(376 Views)

We already tried that to no avail.

0 Kudos
Message 5 of 11
(374 Views)

It sounds like we have two real paths forward for troubleshooting.

 

1) work together to understand the root cause and provide a specific fix for that

2) ignore the root cause and use a brute force method that I'd expect to work independent of the root cause

 

As your time is limited, I lean towards the second option.  I sent you an email to the account associated with this forum account with instructions on how to do that.  Try following those instructions and then updating the firmware to 5.0.0.  I'd expect you'll have a better setup at that point.  We won't know what got you into the current state.  But, you'll also be unblocked so you can focus on the game challenges instead.

0 Kudos
Message 6 of 11
(366 Views)

Thank you! I got the email. It won't be until saturday when we are able to try this. I will post back here after we've tried the fix.

0 Kudos
Message 7 of 11
(364 Views)

Couple of quick tips:

 

1) grab the file now.  The FTP site automatically deletes files periodically.  I'd hate to have you miss it (though, I'd send it again).

2) bring whatever USB drives you have available.  It's better to have too many than to not bring the one(s) that'll work 😃 

0 Kudos
Message 8 of 11
(359 Views)

Can we also get that brute force method? We faced the same exact issue a few hours ago. We didn't know of the 2021.3.1 error and now the RoboRio will not show up in the imaging software.

0 Kudos
Message 9 of 11
(355 Views)

@mdurrani808 wrote:

 We faced the same exact issue a few hours ago. 


It sounds like they're similar but not exact.  For that reason, let's continue this chat in the thread you've created 😃 

0 Kudos
Message 10 of 11
(338 Views)