Troubleshooting Hardware

cancel
Showing results for 
Search instead for 
Did you mean: 

RoboRIO firmware wont flash, corrupted firmware

Hi, when I try to update the firmware or flash a image on our roboRIO (team 5440), I get those error messages:

242119428_1516198825392313_9092555817769397264_n.jpg242421790_876550429638151_6196683783246310213_n.jpgI tried all the steps listed on the error messages, is there anything else that I can do or I really need to contact support at this point?

thank you!

0 Kudos
Message 1 of 8
(540 Views)

Hi Alejandro_K,

 

Thanks for posting. Just to confirm, you have tried with putting the roborio into safe mode?

 

0 Kudos
Message 2 of 8
(536 Views)

Yes, I also tried multiple computers with safe mode enabled on the roboRIO.

0 Kudos
Message 3 of 8
(531 Views)

Let's go ahead and try the USB reset method - I've emailed instructions and how to get the file to the email listed on your profile.

0 Kudos
Message 4 of 8
(524 Views)

Hi, 

We tried all the steps with different USB keys. I didn't work, but we got 2 different errors:
 
-Sometimes, the status would stay lit red for ~ 10 seconds and then turn off. We tried to update the firmware of the roboRIO after it did that, but I didn't work.
 
-Sometimes, the status led would stay lit, but when we let go the reset button, the led would start flashing red.
 
I don't what it means, but we even tried a 32 GB 3.0 USB and it wouldn't work. We tried different power supplies and computers(to try to update the firmware after resets) to see if it may work, but it didn't.
0 Kudos
Message 5 of 8
(493 Views)

It sounds like two different things here we'd want to look at.

 

First, for the devices that quickly go back to flashing red, the USB drives aren't connecting correctly with the roboRIO.  Let's just skip those and move on.  There's nothing you'll be able to do to make this work better.

 

For the others, you'll need to wait a minute or so while the roboRIO remains powered for everything to happen.  You should see some activity on the STATUS LED up until you see it flash twice quickly, wait, and repeat.  Until you see that light pattern, it won't be able to take the firmware.  Let's use one of the USB drives you were using to get into this state and wait a little longer.  If that doesn't work, let me know and we'll find another way to resolve it.

0 Kudos
Message 6 of 8
(371 Views)

Hello, we're encountering a similar issue with one of our roboRIO's. We get similar errors when trying to upgrade the firmware or when formatting it. Interestingly, the imaging tool doesn't show anything for the current image or firmware. We're certain we've isolated the issue since we've trying all the suggested debugging steps without success, and we have another roboRIO that updated without issue. Would it be possible to get assistance with the USB recovery method?

0 Kudos
Message 7 of 8
(336 Views)

I've sent you instructions.  If that doesn't work, please create a new thread.  While similar situations, having different threads helps us have different conversations and not cause confusion when multiple folks are trying to get help at once 😃 

0 Kudos
Message 8 of 8
(327 Views)