SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

"ERROR code 56" when Download systemlink Files

Solved!
Go to solution

Dear ALL,

 

     When I use labview API to download files which are at systemlink server, I got the error code 56.

The systemlink version is 19.5.   The file size is 23MB.

Anyone know how to fixed this problem.

Download All
0 Kudos
Message 1 of 5
(698 Views)

Hi kisyou,

 

does this error occur for any file being downloaded from the server or only for files of a certain size (timeout error)?

 

-Stefan

0 Kudos
Message 2 of 5
(644 Views)

Hi kisyou,

 

From the jpg you attached, it looks like the error message you get is a timeout.  How long does it take for the VI to return that error?  As Stefan asked, do you get the same error when you request a very small file, say only 20kB or 50kB?

 

Brad

0 Kudos
Message 3 of 5
(635 Views)
Solution
Accepted by topic author kisyou

Hi Stefan,

 

   The error is form "http-get vi"  . The defaut timeout is 10s.   When I modify the defaut value, the problem is solved.

 

I think the labview vi should be optimesd the systemlink download vi, then we can change it easily.

 

 

thanks again

0 Kudos
Message 4 of 5
(626 Views)

Dear Brad,

 

   if the file size is small, the timeout time 10s is enough. The problem is api, we can not change the timeout value by a easily way.

 

thanks.

0 Kudos
Message 5 of 5
(623 Views)